summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild
index fca27fefaa43..1b20668b569d 100644
--- a/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild
+++ b/sys-devel/gcc-apple/gcc-apple-4.2.1_p5666-r2.ebuild
@@ -352,8 +352,8 @@ src_install() {
}
pkg_postinst() {
- # beware this also switches when it's on another branch version of GCC
- gcc-config ${CTARGET}-${GCC_VERS}
+ # only activate this compiler if nothing else is activated
+ gcc-config -c >& /dev/null || gcc-config ${CTARGET}-${GCC_VERS}
}
pkg_postrm() {