summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/obexfs/obexfs-0.12.ebuild')
-rw-r--r--sys-fs/obexfs/obexfs-0.12.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/sys-fs/obexfs/obexfs-0.12.ebuild b/sys-fs/obexfs/obexfs-0.12.ebuild
new file mode 100644
index 000000000000..b844b3b5b057
--- /dev/null
+++ b/sys-fs/obexfs/obexfs-0.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="FUSE filesystem interface for ObexFTP"
+HOMEPAGE="http://dev.zuckschwerdt.org/openobex/wiki/ObexFs"
+SRC_URI="mirror://sourceforge/openobex/files/${PN}/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=app-mobilephone/obexftp-0.22
+ sys-fs/fuse
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix building, bug #523062 (from ArchLinux)
+ export OBEXFTP_CFLAGS="-I/usr/include/obexftp -I/usr/include/multicobex -I/usr/include/bfb"
+ export OBEXFTP_LIBS="-lobexftp -lmulticobex -lbfb -lopenobex -lbluetooth"
+}