summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/inotify-tools/Manifest1
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/Manifest b/sys-fs/inotify-tools/Manifest
index 469024843962..a1480516c912 100644
--- a/sys-fs/inotify-tools/Manifest
+++ b/sys-fs/inotify-tools/Manifest
@@ -1 +1,2 @@
DIST inotify-tools-3.14.tar.gz 358772 BLAKE2B 99a0b82942d227e3c237edd6ca07bea68a7bbc07fd97bc5d44cb3c07e5e3bfee9513255fe675667872b027f93edd1137c30b61da7c0ef3986994aa812ca74d15 SHA512 6074d510e89bba5da0d7c4d86f2562c662868666ba0a7ea5d73e53c010a0050dd1fc01959b22cffdb9b8a35bd1b0b43c04d02d6f19927520f05889e8a9297dfb
+DIST inotify-tools-3.20.1.tar.gz 79564 BLAKE2B 4b1235951f55ecb7c6c92b06b68dedebad8677c2265616dddd275bf627034b66b5756cf17a2f68f4201a78b043ec8a0800f115f3952c19875ae7f524b9b21382 SHA512 a97d27e6033036f0db5c0737bee3510206db9f4c843f0d18f1b2e179e838624ea33316c34fd9917c158dbb3580367908e90042fb1bfb146f150c32833b0b2ff2
diff --git a/sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild b/sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild
new file mode 100644
index 000000000000..9f5d0f02a1c8
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-3.20.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/rvoicilas/inotify-tools/wiki"
+SRC_URI="https://github.com/rvoicilas/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # only docs installed are doxygen ones, so use /html
+ local myeconfargs=(
+ --docdir='$(datarootdir)'/doc/${PF}/html
+ $(use_enable doc doxygen)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED%/}" \( -name '*.a*' -o -name '*.la' \) -delete || die
+}