summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2fsprogs/Manifest1
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.44.1.ebuild137
2 files changed, 138 insertions, 0 deletions
diff --git a/sys-fs/e2fsprogs/Manifest b/sys-fs/e2fsprogs/Manifest
index f2bbc74ef4da..5056b7498fda 100644
--- a/sys-fs/e2fsprogs/Manifest
+++ b/sys-fs/e2fsprogs/Manifest
@@ -4,3 +4,4 @@ DIST e2fsprogs-1.43.3.tar.gz 7405892 BLAKE2B 158aeee327a1ca68ce1bda1f97c9fa25ba1
DIST e2fsprogs-1.43.6.tar.gz 7466907 BLAKE2B 6c19c686432b7990900b239c4a1b3b6675b085ca7adfdb4323d1253ee8c83f22f87f67b0b4a843e48cb71322b1a7454b3ceab669f875b71b967e96054a55f1ac SHA512 95e3e7def177de921d3204aeace4cb8243d79872468d3289cace0547798c84e92af253022deb803cd8c045411283b01431728a86b14b9e8b45cdd5dca739db66
DIST e2fsprogs-1.43.9.tar.gz 7470878 BLAKE2B dcc1a6fda87884a0b3b1d49f4116be060bf39c4820246ba6aa7ce61c6735415542f852b36d3c809b2b52782de2ca9ea9a87086a0d4ff71ee217845939aae00f1 SHA512 7bdc5da165b14e6779aedd9243175018ca8cb2bb0f5aad9c3d04f7e0619da2107f37929e6d8027b682145801106f97d1376345c4c30ce64f2b02b716b0c4ba3b
DIST e2fsprogs-1.44.0.tar.gz 7547084 BLAKE2B 32b16453931e33eb21cd42724c7dbe420c21ebdf1650f7eb9b8bc5a1016166e4fd244e97f7dd2c90c934f7244b9cae75bd9d177685b92a9430f29e3349f47b64 SHA512 a084973097bcc806d63b94c106fb22d840a53863c63016d7e0d68094b01679c6985a195e5f7983cfeb356e0a45636a52d6c444af30275c4c42c49c1d94663fed
+DIST e2fsprogs-1.44.1.tar.gz 7534979 BLAKE2B 1d1dcdfebca41d62bb15e0b0464bcfc848b8c1379f89987f91a59093d497536ccd5e80be67419cad05daf694be1629774f881d026ef834e3a61b00dc64f3543b SHA512 acd612a5146e4a07aa7ab3ef1b38c3ef3f27120f65c519dd02d44e48e5814c86d013315eb30c4f08edecaef6f08f0ec0b91fa133ea9dbd769ee29be3f2ae17c9
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.44.1.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.44.1.ebuild
new file mode 100644
index 000000000000..76d036d2679c
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.44.1.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+case ${PV} in
+*_pre*) UP_PV="${PV%_pre*}-WIP-${PV#*_pre}" ;;
+*) UP_PV=${PV} ;;
+esac
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${PN}-${UP_PV}.tar.gz
+ mirror://kernel/linux/kernel/people/tytso/e2fsprogs/v${UP_PV}/${PN}-${UP_PV}.tar.gz
+ elibc_mintlib? ( mirror://gentoo/${PN}-1.42.9-mint-r1.patch.xz )"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~m68k-mint"
+IUSE="fuse nls static-libs elibc_FreeBSD"
+
+RDEPEND="~sys-libs/${PN}-libs-${PV}
+ >=sys-apps/util-linux-2.16
+ fuse? ( sys-fs/fuse:0 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ sys-apps/texinfo"
+
+S="${WORKDIR}/${P%_pre*}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.41.8-makefile.patch
+ "${FILESDIR}"/${PN}-1.40-fbsd.patch
+ "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
+
+ # Upstream patches (can usually removed with next version bump)
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-mint* ]] ; then
+ PATCHES+=( "${WORKDIR}"/${PN}-1.42.9-mint-r1.patch )
+ fi
+
+ default
+
+ # blargh ... trick e2fsprogs into using e2fsprogs-libs
+ rm -rf doc
+ sed -i -r \
+ -e 's:@LIBINTL@:@LTLIBINTL@:' \
+ -e '/^(STATIC_)?LIB(COM_ERR|SS)/s:[$][(]LIB[)]/lib([^@]*)@(STATIC_)?LIB_EXT@:-l\1:' \
+ -e '/^DEP(STATIC_)?LIB(COM_ERR|SS)/s:=.*:=:' \
+ MCONFIG.in || die "muck libs" #122368
+ sed -i -r \
+ -e '/^LIB_SUBDIRS/s:lib/(et|ss)::g' \
+ Makefile.in || die "remove subdirs"
+ ln -s $(which mk_cmds) lib/ss/ || die
+
+ # Avoid rebuild
+ echo '#include_next <ss/ss_err.h>' > lib/ss/ss_err.h
+}
+
+src_configure() {
+ # Keep the package from doing silly things #261411
+ export VARTEXFONTS="${T}/fonts"
+
+ # needs open64() prototypes and friends
+ append-cppflags -D_GNU_SOURCE
+
+ local myeconfargs=(
+ --with-root-prefix="${EPREFIX}/"
+ --enable-symlink-install
+ $(tc-is-static-only || echo --enable-elf-shlibs)
+ $(tc-has-tls || echo --disable-tls)
+ --without-included-gettext
+ $(use_enable fuse fuse2fs)
+ $(use_enable nls)
+ --disable-libblkid
+ --disable-libuuid
+ --disable-fsck
+ --disable-uuidd
+ )
+ ac_cv_path_LDCONFIG=: econf "${myeconfargs[@]}"
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to https://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+}
+
+src_compile() {
+ emake V=1 COMPILE_ET=compile_et MK_CMDS=mk_cmds
+
+ # Build the FreeBSD helper
+ if use elibc_FreeBSD ; then
+ cp "${FILESDIR}"/fsck_ext2fs.c .
+ emake V=1 fsck_ext2fs
+ fi
+}
+
+src_install() {
+ # need to set root_libdir= manually as any --libdir options in the
+ # econf above (i.e. multilib) will screw up the default #276465
+ emake \
+ STRIP=: \
+ root_libdir="${EPREFIX}/usr/$(get_libdir)" \
+ DESTDIR="${D}" \
+ install install-libs
+ dodoc README RELEASE-NOTES
+
+ insinto /etc
+ doins "${FILESDIR}"/e2fsck.conf
+
+ # Move shared libraries to /lib/, install static libraries to
+ # /usr/lib/, and install linker scripts to /usr/lib/.
+ gen_usr_ldscript -a e2p ext2fs
+ # configure doesn't have an option to disable static libs :/
+ if ! use static-libs ; then
+ find "${D}" -name '*.a' -delete || die
+ fi
+
+ if use elibc_FreeBSD ; then
+ # Install helpers for us
+ into /
+ dosbin "${S}"/fsck_ext2fs
+ doman "${FILESDIR}"/fsck_ext2fs.8
+
+ # filefrag is linux only
+ rm \
+ "${ED%/}"/usr/sbin/filefrag \
+ "${ED%/}"/usr/share/man/man8/filefrag.8 || die
+ fi
+}