summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2tools/Manifest1
-rw-r--r--sys-fs/e2tools/e2tools-0.0.16.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/e2tools/Manifest b/sys-fs/e2tools/Manifest
index 650ff0ae3566..5795bfbcb4d4 100644
--- a/sys-fs/e2tools/Manifest
+++ b/sys-fs/e2tools/Manifest
@@ -1 +1,2 @@
+DIST e2tools-0.0.16.4.tar.gz 70444 BLAKE2B 3db75ca2ecca27bfbd65890f595c9523f373555e771f21113ca1c3bd1f08d74f5e1d70db39bbe0ac215a1766e702a37c2c2752f671320d45f3bfa56b39fd8296 SHA512 35bda0005d0ba4d9541eabf45bd9bed0e7e85144dce88c3bd8afd8eb5ed5db610bc5654aee82978b2a4955d363fd5af4ff40667fa8001955267c96cb84e6792b
DIST e2tools-0.0.16.tar.gz 72333 BLAKE2B c843938b2217bfe1e36fcb1197b3a0d27d6fb5867c99d89b5e2af2eebe807aa6cf264b8fb0ea5573f22507f19e676eb124ef694866b8f76bf815880ce2a0f876 SHA512 8be79385c07027286951755a7ca0407215b517d4abba5546a0958fcb5e8feaffc993d35dd56bde39e14d397875941fc812c713db3d27247cd8e9ee7ed6a153b4
diff --git a/sys-fs/e2tools/e2tools-0.0.16.4.ebuild b/sys-fs/e2tools/e2tools-0.0.16.4.ebuild
new file mode 100644
index 000000000000..e869d21197a5
--- /dev/null
+++ b/sys-fs/e2tools/e2tools-0.0.16.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="utilities to read, write, and manipulate files in an ext2/ext3 filesystem"
+HOMEPAGE="http://home.earthlink.net/~k_sheff/sw/e2tools/"
+SRC_URI="https://github.com/ndim/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-fs/e2fsprogs
+ sys-libs/e2fsprogs-libs"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # The configure script is ancient.
+ #export CONFIG_SHELL="/bin/bash"
+ tc-export CC
+ default
+}