summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/efivar')
-rw-r--r--sys-libs/efivar/Manifest4
-rw-r--r--sys-libs/efivar/efivar-30.ebuild49
-rw-r--r--sys-libs/efivar/efivar-31.ebuild37
-rw-r--r--sys-libs/efivar/efivar-32-r1.ebuild42
-rw-r--r--sys-libs/efivar/efivar-32.ebuild38
-rw-r--r--sys-libs/efivar/efivar-35.ebuild38
6 files changed, 0 insertions, 208 deletions
diff --git a/sys-libs/efivar/Manifest b/sys-libs/efivar/Manifest
index c96ce8a448ad..c8afcced10cb 100644
--- a/sys-libs/efivar/Manifest
+++ b/sys-libs/efivar/Manifest
@@ -1,5 +1 @@
-DIST efivar-30.tar.bz2 73202 BLAKE2B 6b146cb6d664e3419361e72ab6fd1578522e7fc219613ae21566cb40a700fe70f18750cc753338faca2ad078e2bc933fb33a3a4cdfb148eabb0fc71b1319fb71 SHA512 0a6d7175762011c3fc67b531d3d19a45e82195c729b9ff498be02b3a6a73f6c3c4f9e14a27470c6744b741d7d54db9ef24c7882639af25fca1034b7b9f641b39
-DIST efivar-31.tar.bz2 82404 BLAKE2B d339aa8ab7dcd6a60cb067fccfbc2c42407fba211ca96eb39f227d57e9403462505940f427651dfaffa8272c9edfe70898f181b9f6ecddbae4745eb3262de949 SHA512 5055f690fd99cf59895dcf3d11103494d917d4923567626f0bee816ea5e4dd56cec23627ede5f21bdc57b7306522471ad19cc8ab22ae94591dbd1925c084f163
-DIST efivar-32.tar.gz 108102 BLAKE2B 7f9d27433b40ec6c044ab34ccc697001ad23e39a46862d2e04db0f9a3dfc26ae53b46a3c3a8c957bf76df0969710f78249f72f7bf38e67c0aa902034a07acf8f SHA512 e73eae182fd645183dfe587591a286670ee1123a113e3e19e4070fb910ab7794e320defdc0597540df7664947f2a0497abbb763a19b4dfa40511a512c7f3e490
-DIST efivar-35.tar.bz2 95528 BLAKE2B c936114aade7a586f707af2464d350703234e0c3fb786fb568590737fb3939c3f74ff813f4f188aec230d75e75e73b0d07cbff5860f0b9f1285d2780b29c7689 SHA512 c7ba60b2112053f088ad0b74aaa834860601b7fe17118c35b012050176f5205d948fba9c4b6de35991249f702e3bc24832539e2eb3c235c4188e1eabc78965ee
DIST efivar-37.tar.bz2 109431 BLAKE2B 813d477d31562b773f6e19f20e9e237b94beed437ce221771770e7d46ff0e657530285f035dc942cc20609185be92dc50319bfe8e10dee642c8bd88403ef6ffe SHA512 305a82ed103c7e3d8f723934019d552677c73558768dd5341f87d0364f5c60824d24f5a8e1bf90075e825908085083d4ecdccec5ac757fd38ee6ac8fea28c3e4
diff --git a/sys-libs/efivar/efivar-30.ebuild b/sys-libs/efivar/efivar-30.ebuild
deleted file mode 100644
index e45c9ae1e97a..000000000000
--- a/sys-libs/efivar/efivar-30.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Tools and library to manipulate EFI variables"
-HOMEPAGE="https://github.com/rhinstaller/efivar"
-SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0/1"
-KEYWORDS="amd64 ~arm ~arm64 ia64 x86"
-
-RDEPEND="dev-libs/popt"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-3.18
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- sed -i -e s/-Werror// gcc.specs || die
-}
-
-src_configure() {
- tc-export CC
-
- # https://github.com/rhinstaller/efivar/issues/64
- append-cflags -flto
-
- tc-ld-disable-gold
- export libdir="/usr/$(get_libdir)"
- unset LIBS # Bug 562004
-}
-
-src_compile() {
- # Avoid building static binary/libs
- opts=(
- BINTARGETS=efivar
- STATICLIBTARGETS=
- )
- emake "${opts[@]}"
-}
-
-src_install() {
- emake "${opts[@]}" DESTDIR="${D}" install
-}
diff --git a/sys-libs/efivar/efivar-31.ebuild b/sys-libs/efivar/efivar-31.ebuild
deleted file mode 100644
index 6eccd1d7ed33..000000000000
--- a/sys-libs/efivar/efivar-31.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Tools and library to manipulate EFI variables"
-HOMEPAGE="https://github.com/rhinstaller/efivar"
-SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0/1"
-KEYWORDS="amd64 ~arm ~arm64 ia64 x86"
-
-RDEPEND="dev-libs/popt"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-3.18
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- sed -i -e s/-Werror// gcc.specs || die
-}
-
-src_configure() {
- tc-export CC
- tc-ld-disable-gold
- export libdir="/usr/$(get_libdir)"
- unset LIBS # Bug 562004
-
- if [[ -n ${GCC_SPECS} ]]; then
- # The environment overrides the command line.
- GCC_SPECS+=":${S}/gcc.specs"
- fi
-}
diff --git a/sys-libs/efivar/efivar-32-r1.ebuild b/sys-libs/efivar/efivar-32-r1.ebuild
deleted file mode 100644
index b9a3ef43942b..000000000000
--- a/sys-libs/efivar/efivar-32-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Tools and library to manipulate EFI variables"
-HOMEPAGE="https://github.com/rhinstaller/efivar"
-#SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
-SRC_URI="https://github.com/rhinstaller/efivar/archive/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/1"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
-
-RDEPEND="dev-libs/popt"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-3.18
- virtual/pkgconfig
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-efi_guid_ux_capsule.patch"
-)
-
-src_prepare() {
- default
- sed -i -e s/-Werror// gcc.specs || die
-}
-
-src_configure() {
- tc-export CC
- tc-ld-disable-gold
- export libdir="/usr/$(get_libdir)"
- unset LIBS # Bug 562004
-
- if [[ -n ${GCC_SPECS} ]]; then
- # The environment overrides the command line.
- GCC_SPECS+=":${S}/gcc.specs"
- fi
-}
diff --git a/sys-libs/efivar/efivar-32.ebuild b/sys-libs/efivar/efivar-32.ebuild
deleted file mode 100644
index bec7c857931f..000000000000
--- a/sys-libs/efivar/efivar-32.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Tools and library to manipulate EFI variables"
-HOMEPAGE="https://github.com/rhinstaller/efivar"
-#SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
-SRC_URI="https://github.com/rhinstaller/efivar/archive/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0/1"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
-
-RDEPEND="dev-libs/popt"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-3.18
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- sed -i -e s/-Werror// gcc.specs || die
-}
-
-src_configure() {
- tc-export CC
- tc-ld-disable-gold
- export libdir="/usr/$(get_libdir)"
- unset LIBS # Bug 562004
-
- if [[ -n ${GCC_SPECS} ]]; then
- # The environment overrides the command line.
- GCC_SPECS+=":${S}/gcc.specs"
- fi
-}
diff --git a/sys-libs/efivar/efivar-35.ebuild b/sys-libs/efivar/efivar-35.ebuild
deleted file mode 100644
index b050cddcf60d..000000000000
--- a/sys-libs/efivar/efivar-35.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Tools and library to manipulate EFI variables"
-HOMEPAGE="https://github.com/rhinstaller/efivar"
-SRC_URI="https://github.com/rhinstaller/efivar/releases/download/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0/1"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
-
-RDEPEND="dev-libs/popt"
-DEPEND="${RDEPEND}
- >=sys-kernel/linux-headers-3.18
- virtual/pkgconfig
-"
-
-src_prepare() {
- default
- sed -i -e 's/-Werror //' gcc.specs || die
-}
-
-src_configure() {
- tc-export CC
- export CC_FOR_BUILD=$(tc-getBUILD_CC)
- tc-ld-disable-gold
- export libdir="/usr/$(get_libdir)"
- unset LIBS # Bug 562004
-
- if [[ -n ${GCC_SPECS} ]]; then
- # The environment overrides the command line.
- GCC_SPECS+=":${S}/gcc.specs"
- fi
-}