summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/files/gpm-1.20.7-sysmacros.patch30
-rw-r--r--sys-libs/gpm/gpm-1.20.7-r2.ebuild1
2 files changed, 31 insertions, 0 deletions
diff --git a/sys-libs/gpm/files/gpm-1.20.7-sysmacros.patch b/sys-libs/gpm/files/gpm-1.20.7-sysmacros.patch
new file mode 100644
index 000000000000..d8ab2d191f7c
--- /dev/null
+++ b/sys-libs/gpm/files/gpm-1.20.7-sysmacros.patch
@@ -0,0 +1,30 @@
+From b350aee4ea5785a75cb6ad770f6b768c506ebb70 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 14 Mar 2016 15:39:54 -0400
+Subject: [PATCH] fix building w/newer glibc
+
+Linux C libraries are looking to disentangle sysmacros.h from the
+sys/types.h include, so make sure we pull in the header when it is
+found.
+---
+ src/daemon/open_console.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/daemon/open_console.c b/src/daemon/open_console.c
+index 4d6c0af..6dd43e6 100644
+--- a/src/daemon/open_console.c
++++ b/src/daemon/open_console.c
+@@ -24,6 +24,10 @@
+ #include <sys/types.h> /* major() */
+ #include <sys/ioctl.h> /* ioctl */
+
++#ifdef HAVE_SYS_SYSMACROS_H
++#include <sys/sysmacros.h> /* major() w/newer glibc */
++#endif
++
+ /* Linux specific (to be outsourced in gpm2 */
+ #include <linux/serial.h> /* for serial console check */
+ #include <asm/ioctls.h> /* for serial console check */
+--
+2.6.2
+
diff --git a/sys-libs/gpm/gpm-1.20.7-r2.ebuild b/sys-libs/gpm/gpm-1.20.7-r2.ebuild
index af8bb4ae2669..8a191ddd4790 100644
--- a/sys-libs/gpm/gpm-1.20.7-r2.ebuild
+++ b/sys-libs/gpm/gpm-1.20.7-r2.ebuild
@@ -29,6 +29,7 @@ DEPEND=">=sys-libs/ncurses-5.9-r3[${MULTILIB_USEDEP}]
virtual/yacc"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-sysmacros.patch
# fix ABI values
sed -i \
-e '/^abi_lev=/s:=.*:=1:' \