summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libnih/files')
-rw-r--r--sys-libs/libnih/files/libnih-1.0.3-expat-2.2.5.patch15
-rw-r--r--sys-libs/libnih/files/libnih-1.0.3-fno-common.patch11
-rw-r--r--sys-libs/libnih/files/libnih-1.0.3-glibc-2.24.patch57
-rw-r--r--sys-libs/libnih/files/libnih-1.0.3-optional-dbus.patch40
-rw-r--r--sys-libs/libnih/files/libnih-1.0.3-pkg-config.patch24
-rw-r--r--sys-libs/libnih/files/libnih-1.0.3-signal-race.patch44
6 files changed, 0 insertions, 191 deletions
diff --git a/sys-libs/libnih/files/libnih-1.0.3-expat-2.2.5.patch b/sys-libs/libnih/files/libnih-1.0.3-expat-2.2.5.patch
deleted file mode 100644
index 02b5e4c0a9e2..000000000000
--- a/sys-libs/libnih/files/libnih-1.0.3-expat-2.2.5.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Description: Adapt test suite to expat 2.2.5
-Author: Axel Beckert <abe@debian.org>
-Bug-Debian: https://bugs.debian.org/886416
-
---- a/nih-dbus-tool/tests/test_parse.c
-+++ b/nih-dbus-tool/tests/test_parse.c
-@@ -7950,7 +7950,7 @@
-
- TEST_EQ_P (node, NULL);
-
-- TEST_FILE_EQ (output, ("test:foo:2:0: "
-+ TEST_FILE_EQ (output, ("test:foo:1:36: "
- "Invalid object path in <node> name attribute\n"));
- TEST_FILE_END (output);
- TEST_FILE_RESET (output);
diff --git a/sys-libs/libnih/files/libnih-1.0.3-fno-common.patch b/sys-libs/libnih/files/libnih-1.0.3-fno-common.patch
deleted file mode 100644
index 2b3a9cef5b48..000000000000
--- a/sys-libs/libnih/files/libnih-1.0.3-fno-common.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/nih-dbus-tool/output.h
-+++ b/nih-dbus-tool/output.h
-@@ -27,7 +27,7 @@
-
- NIH_BEGIN_EXTERN
-
--char *output_package;
-+extern char *output_package;
-
- int output (const char *source_path, int source_fd,
- const char *header_path, int header_fd,
diff --git a/sys-libs/libnih/files/libnih-1.0.3-glibc-2.24.patch b/sys-libs/libnih/files/libnih-1.0.3-glibc-2.24.patch
deleted file mode 100644
index 9b90f3539d7c..000000000000
--- a/sys-libs/libnih/files/libnih-1.0.3-glibc-2.24.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-With glibc >= 2.24, raise() temporarily blocks signals to make this
-function async-signal-safe. This has the consequence that the SIGCONT
-signal send by the call to PTRACE_CONT is delivered slightly later. In
-turn it means the next ptrace event received is the SIGCONT signal
-instead of the expected one.
-
-Unfortunately the libnih testsuite has very precise expectations, and
-do not expect such an event. Fix that by catching it and waiting for the
-following event.
-
---- libnih-1.0.3.orig/nih/tests/test_child.c
-+++ libnih-1.0.3/nih/tests/test_child.c
-@@ -360,6 +360,14 @@ test_poll (void)
-
- waitid (P_PID, pid, &siginfo, WSTOPPED | WNOWAIT);
-
-+ /* ptrace might catch the SIGCONT emitted with PTRACE_CONT, catch it
-+ and wait for the next event.
-+ */
-+ if (siginfo.si_code == CLD_TRAPPED && siginfo.si_status == SIGCONT) {
-+ assert0 (ptrace (PTRACE_CONT, pid, NULL, NULL));
-+ waitid (P_PID, pid, &siginfo, WSTOPPED | WNOWAIT);
-+ }
-+
- watch = nih_child_add_watch (NULL, pid, NIH_CHILD_TRAPPED,
- my_handler, &watch);
-
-@@ -420,6 +428,14 @@ test_poll (void)
- /* Wait for ptrace to stop the parent (signalling the fork) */
- waitid (P_PID, pid, &siginfo, WSTOPPED | WNOWAIT);
-
-+ /* ptrace might catch the SIGCONT emitted with PTRACE_CONT, catch it
-+ and wait for the next event.
-+ */
-+ if (siginfo.si_code == CLD_TRAPPED && siginfo.si_status == SIGCONT) {
-+ assert0 (ptrace (PTRACE_CONT, pid, NULL, NULL));
-+ waitid (P_PID, pid, &siginfo, WSTOPPED | WNOWAIT);
-+ }
-+
- /* Will be able to get the child pid now, we have to do it here
- * because we want to wait on it to ensure the test is synchronous;
- * otherwise nih_child_poll() could actually eat the child event
-@@ -489,6 +505,14 @@ test_poll (void)
-
- waitid (P_PID, pid, &siginfo, WSTOPPED | WNOWAIT);
-
-+ /* ptrace might catch the SIGCONT emitted with PTRACE_CONT, catch it
-+ and wait for the next event.
-+ */
-+ if (siginfo.si_code == CLD_TRAPPED && siginfo.si_status == SIGCONT) {
-+ assert0 (ptrace (PTRACE_CONT, pid, NULL, NULL));
-+ waitid (P_PID, pid, &siginfo, WSTOPPED | WNOWAIT);
-+ }
-+
- watch = nih_child_add_watch (NULL, pid, NIH_CHILD_PTRACE,
- my_handler, &watch);
-
diff --git a/sys-libs/libnih/files/libnih-1.0.3-optional-dbus.patch b/sys-libs/libnih/files/libnih-1.0.3-optional-dbus.patch
deleted file mode 100644
index 49ad68a07b5a..000000000000
--- a/sys-libs/libnih/files/libnih-1.0.3-optional-dbus.patch
+++ /dev/null
@@ -1,40 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -23,12 +23,21 @@
- PKG_PROG_PKG_CONFIG([0.22])
-
- # Checks for libraries.
--PKG_CHECK_MODULES([DBUS], [dbus-1 >= 1.2.16])
--AC_CHECK_LIB([expat], [XML_ParserCreate],
-+AC_ARG_WITH([dbus],
-+ [AS_HELP_STRING([--without-dbus],
-+ [disable support for dbus])],
-+ [],
-+ [with_dbus=yes])
-+
-+AS_IF([test "x$with_dbus" != xno],[
-+ PKG_CHECK_MODULES([DBUS], [dbus-1 >= 1.2.16])
-+ AC_CHECK_LIB([expat], [XML_ParserCreate],
- [AC_CHECK_LIB([expat], [XML_StopParser],
- [AC_SUBST([EXPAT_LIBS], [-lexpat])],
- [AC_MSG_ERROR([expat >= 2.0.0 required])])],
-- [AC_MSG_ERROR([expat library not found])])
-+ [AC_MSG_ERROR([expat library not found])])])
-+
-+AM_CONDITIONAL([DBUS_SUPPORT], [test "x$with_dbus" != xno])
-
- # Checks for header files.
- AC_CHECK_HEADERS([valgrind/valgrind.h])
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -1,6 +1,9 @@
- ## Process this file with automake to produce Makefile.in
-
--SUBDIRS = m4 intl nih nih-dbus nih-dbus-tool po
-+SUBDIRS = m4 intl nih po
-+if DBUS_SUPPORT
-+SUBDIRS += nih-dbus nih-dbus-tool
-+endif
-
- EXTRA_DIST = HACKING
-
diff --git a/sys-libs/libnih/files/libnih-1.0.3-pkg-config.patch b/sys-libs/libnih/files/libnih-1.0.3-pkg-config.patch
deleted file mode 100644
index 6516de799432..000000000000
--- a/sys-libs/libnih/files/libnih-1.0.3-pkg-config.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- a/nih-dbus/Makefile.am
-+++ b/nih-dbus/Makefile.am
-@@ -49,7 +49,7 @@
- test_dbus.h
-
-
--pkgconfigdir = $(prefix)/lib/pkgconfig
-+pkgconfigdir = $(libdir)/pkgconfig
- pkgconfig_DATA = libnih-dbus.pc
-
-
-
---- a/nih/Makefile.am
-+++ b/nih/Makefile.am
-@@ -71,7 +71,7 @@
- test_hash.h
-
-
--pkgconfigdir = $(prefix)/lib/pkgconfig
-+pkgconfigdir = $(libdir)/pkgconfig
- pkgconfig_DATA = libnih.pc
-
-
-
diff --git a/sys-libs/libnih/files/libnih-1.0.3-signal-race.patch b/sys-libs/libnih/files/libnih-1.0.3-signal-race.patch
deleted file mode 100644
index 364af7f5383e..000000000000
--- a/sys-libs/libnih/files/libnih-1.0.3-signal-race.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/nih/signal.c
-+++ b/nih/signal.c
-@@ -337,17 +337,37 @@
-
- nih_signal_init ();
-
-+ /* Since this poller runs w/out signals masked, we do not want to try
-+ * and clear any other signals (like zeroing the caught array at the
-+ * end). If we do that, we open a race:
-+ * - Walk the list of signals.
-+ * - First one is not set so we move on to the second one.
-+ * - First signal comes in while processing second and increments the
-+ * caught array entry.
-+ * - Finish walking the whole list.
-+ * - Zero out the whole list and thus throw away the first signal.
-+ * Since the signal handlers can take any length of time, this race
-+ * can be open for a variable amount of time.
-+ */
-+
- NIH_LIST_FOREACH_SAFE (nih_signals, iter) {
- NihSignal *signal = (NihSignal *)iter;
-
- if (! signals_caught[signal->signum])
- continue;
-
-+ /* Now that we know we're going to process this signal, clear
-+ * out all pending counts for it. There is a slight race here
-+ * where the same signal can come in, but the API has never
-+ * guaranteed exact coverage since POSIX does not provide it --
-+ * more than one signal can be collapsed into one event. All
-+ * we can guarantee is that we'll notice signals that come in
-+ * once the handler runs.
-+ */
-+ signals_caught[signal->signum] = 0;
-+
- signal->handler (signal->data, signal);
- }
--
-- for (s = 0; s < NUM_SIGNALS; s++)
-- signals_caught[s] = 0;
- }
-
-
-