summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libseccomp/libseccomp-0.1.0.ebuild')
-rw-r--r--sys-libs/libseccomp/libseccomp-0.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-libs/libseccomp/libseccomp-0.1.0.ebuild b/sys-libs/libseccomp/libseccomp-0.1.0.ebuild
new file mode 100644
index 000000000000..48dd73fe2b31
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-0.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# Note: USE=static-libs isn't great -- only PIC objects are provided.
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="http://sourceforge.net/projects/libseccomp/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs tools"
+
+src_prepare() {
+ sed -i \
+ -e "/^SUBDIRS_BUILD/s:=.*:= src $(usex tools tools ''):" \
+ Makefile || die
+}
+
+src_test() {
+ emake SUBDIRS_BUILD='tools tests'
+ cd tests
+ ./regression
+}
+
+src_install() {
+ default
+ use tools && dobin tools/{bpf_{disasm,sim},sys_{inspector,resolver}}
+ use static-libs && dolib.a src/libseccomp.a
+}