summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/libseccomp')
-rw-r--r--sys-libs/libseccomp/Manifest1
-rw-r--r--sys-libs/libseccomp/libseccomp-2.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-libs/libseccomp/Manifest b/sys-libs/libseccomp/Manifest
index 61e0ddeaaddf..708b42d3a6ce 100644
--- a/sys-libs/libseccomp/Manifest
+++ b/sys-libs/libseccomp/Manifest
@@ -1,3 +1,4 @@
DIST libseccomp-2.1.1.tar.gz 113133 SHA256 8812c11e407c383f5ad6afb84a88e5a0224477bcfe8ff03f0c548e5abaac841c SHA512 1f2916d80a9b9937d2ab9ecf9c4f1e2a8ffc27f90f14e8481eb2f32c8122ea1756950f753f25fb571053f492cc97c8792760e0f058e7ea07ec4bb442508d1112 WHIRLPOOL 77db55f9317e27930b6fd7e83d122b1dd460849bbf9910d7619424d791b1ecd96ffbc5f741cd35e89f27cdc0ab537d5c7c9febaafbf1556c932b9774b80a8643
DIST libseccomp-2.2.0.tar.gz 516697 SHA256 5aa8a230f8529d6ee777098550245e43d2247395fdfd5a2176e28cf7236f1b10 SHA512 c013fdfc868d19bc6703019e91f4bea9c2b7472417a9f0df4fc593fc5fdf29bf535f4b32defd738652838799483684ca18a57e32eeb4b7fb3512b07fb2a440c5 WHIRLPOOL ec1e42186d813d8cf9aea248c27e732162bd4016f06385b4d66ce573f76cb45418211f7b5c06ccb4a35a3c56ce97619827c21a3910e717e35a7c343ee4adf8dc
DIST libseccomp-2.2.3.tar.gz 522755 SHA256 d9b400b703cab7bb04b84b9b6e52076a630b673819d7541757bcc16467b6d49e SHA512 e7bce0627c7ee107ea4780a6d2d7f24da162fdb5a85fc064c94e629918de2ee7ce7ed5ed98490f17392d9ca7ec1204945db3fea4415fae4370495b71c9edb61e WHIRLPOOL a32105a4cf3b514531e3cd7f1c703305318eceb90ef030317139fe08fe62fd14670b5ddc6f0dc8165cac23da1df89ee6efea3c366cec64102194c12ae53eac4f
+DIST libseccomp-2.3.0.tar.gz 546948 SHA256 d756e3a77578259a808698a50c43d44612aae3339ea42ab5b15ea983f26b901d SHA512 398643af0920ff446b37a74e48f7a96ad2bec4f514e92fc6f8242b7515dcb8f5d06c2894790b22f62387c2d9b75efd54a4d5944f973239a05f06ec840f2a5a0b WHIRLPOOL 45ced8e8cc5636fdd9861408582277183daf7c6e3b35bc9f16ea16249a27f86cf82ec45c7e9f898a843b91b9c37ff5ab5b0a4a2b79ac2564e92cecaf8a39d61d
diff --git a/sys-libs/libseccomp/libseccomp-2.3.0.ebuild b/sys-libs/libseccomp/libseccomp-2.3.0.ebuild
new file mode 100644
index 000000000000..ad6a115e0fe8
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-2.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# TODO: Add python support.
+
+EAPI="5"
+
+inherit eutils multilib-minimal
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="https://github.com/seccomp/libseccomp"
+SRC_URI="https://github.com/seccomp/libseccomp/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~s390 ~x86"
+IUSE="static-libs"
+
+# We need newer kernel headers; we don't keep strict control of the exact
+# version here, just be safe and pull in the latest stable ones. #551248
+DEPEND=">=sys-kernel/linux-headers-4.3"
+
+src_prepare() {
+ sed -i \
+ -e '/_LDFLAGS/s:-static::' \
+ tools/Makefile.in || die
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable static-libs static) \
+ --disable-python
+}
+
+multilib_src_install_all() {
+ find "${ED}" -name libseccomp.la -delete
+ einstalldocs
+}