summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/zlib/zlib-1.2.5.1.ebuild')
-rw-r--r--sys-libs/zlib/zlib-1.2.5.1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/sys-libs/zlib/zlib-1.2.5.1.ebuild b/sys-libs/zlib/zlib-1.2.5.1.ebuild
deleted file mode 100644
index 7fff535df92e..000000000000
--- a/sys-libs/zlib/zlib-1.2.5.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils toolchain-funcs multilib
-
-DESCRIPTION="Standard (de)compression library"
-HOMEPAGE="http://www.zlib.net/"
-SRC_URI="http://www.gzip.org/zlib/${P}.tar.gz
- http://www.zlib.net/current/beta/${P}.tar.gz"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE=""
-
-RDEPEND="!<dev-libs/libxml2-2.7.7" #309623
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # trust exit status of the compiler rather than stderr #55434
- # -if test "`(...) 2>&1`" = ""; then
- # +if (...) 2>/dev/null; then
- sed -i 's|\<test "`\([^"]*\) 2>&1`" = ""|\1 2>/dev/null|' configure || die
-
- epatch "${FILESDIR}"/${P}-version.patch
- epatch "${FILESDIR}"/${P}-symlinks.patch
-}
-
-echoit() { echo "$@"; "$@"; }
-src_compile() {
- case ${CHOST} in
- *-mingw*|mingw*)
- emake -f win32/Makefile.gcc STRIP=true PREFIX=${CHOST}- || die
- sed \
- -e 's|@prefix@|/usr|g' \
- -e 's|@exec_prefix@|${prefix}|g' \
- -e 's|@libdir@|${exec_prefix}/'$(get_libdir)'|g' \
- -e 's|@sharedlibdir@|${exec_prefix}/'$(get_libdir)'|g' \
- -e 's|@includedir@|${prefix}/include|g' \
- -e 's|@VERSION@|'${PV}'|g' \
- zlib.pc.in > zlib.pc || die
- ;;
- *) # not an autoconf script, so can't use econf
- echoit ./configure --shared --prefix=/usr --libdir=/usr/$(get_libdir) || die
- emake || die
- ;;
- esac
-}
-
-src_install() {
- case ${CHOST} in
- *-mingw*|mingw*)
- emake -f win32/Makefile.gcc install \
- BINARY_PATH="${D}/usr/bin" \
- LIBRARY_PATH="${D}/usr/$(get_libdir)" \
- INCLUDE_PATH="${D}/usr/include" \
- SHARED_MODE=1 \
- || die
- insinto /usr/share/pkgconfig
- doins zlib.pc || die
- ;;
-
- *)
- emake install DESTDIR="${D}" LDCONFIG=: || die
- gen_usr_ldscript -a z
- ;;
- esac
-
- dodoc FAQ README ChangeLog doc/*.txt
-}