summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.31-r6.ebuild5
-rw-r--r--sys-libs/glibc/glibc-2.32.ebuild5
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild5
3 files changed, 0 insertions, 15 deletions
diff --git a/sys-libs/glibc/glibc-2.31-r6.ebuild b/sys-libs/glibc/glibc-2.31-r6.ebuild
index 73a26abf452b..c010b578953a 100644
--- a/sys-libs/glibc/glibc-2.31-r6.ebuild
+++ b/sys-libs/glibc/glibc-2.31-r6.ebuild
@@ -420,11 +420,6 @@ want__thread() {
use_multiarch() {
# Allow user to disable runtime arch detection in multilib.
use multiarch || return 1
- # multiarch does not work on ppc with cache-block not equal to 128 bytes
- # and breaks memset:
- # https://sourceware.org/PR26522
- # https://bugs.gentoo.org/737996
- [[ $(tc-arch ${CTARGET}) == ppc ]] && return 1
# Make sure binutils is new enough to support indirect functions,
# #336792. This funky sed supports gold and bfd linkers.
local bver nver
diff --git a/sys-libs/glibc/glibc-2.32.ebuild b/sys-libs/glibc/glibc-2.32.ebuild
index a53946fa5628..2a750041ae48 100644
--- a/sys-libs/glibc/glibc-2.32.ebuild
+++ b/sys-libs/glibc/glibc-2.32.ebuild
@@ -420,11 +420,6 @@ want__thread() {
use_multiarch() {
# Allow user to disable runtime arch detection in multilib.
use multiarch || return 1
- # multiarch does not work on ppc with cache-block not equal to 128 bytes
- # and breaks memset:
- # https://sourceware.org/PR26522
- # https://bugs.gentoo.org/737996
- [[ $(tc-arch ${CTARGET}) == ppc ]] && return 1
# Make sure binutils is new enough to support indirect functions,
# #336792. This funky sed supports gold and bfd linkers.
local bver nver
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 8430fbb242de..ef9ad2c0051e 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -421,11 +421,6 @@ want__thread() {
use_multiarch() {
# Allow user to disable runtime arch detection in multilib.
use multiarch || return 1
- # multiarch does not work on ppc with cache-block not equal to 128 bytes
- # and breaks memset:
- # https://sourceware.org/PR26522
- # https://bugs.gentoo.org/737996
- [[ $(tc-arch ${CTARGET}) == ppc ]] && return 1
# Make sure binutils is new enough to support indirect functions,
# #336792. This funky sed supports gold and bfd linkers.
local bver nver