summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'virtual/wine')
-rw-r--r--virtual/wine/metadata.xml5
-rw-r--r--virtual/wine/wine-0-r10.ebuild (renamed from virtual/wine/wine-0-r5.ebuild)25
-rw-r--r--virtual/wine/wine-0-r6.ebuild33
3 files changed, 11 insertions, 52 deletions
diff --git a/virtual/wine/metadata.xml b/virtual/wine/metadata.xml
index de062ba7a89a..a5e53660da5c 100644
--- a/virtual/wine/metadata.xml
+++ b/virtual/wine/metadata.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>wine@gentoo.org</email>
<name>Wine</name>
</maintainer>
<use>
- <flag name="d3d9">Enable Ixit's Gallium Nine Patchset</flag>
+ <flag name="proton">Enable Valve Software's fork of Wine</flag>
<flag name="staging">Enable Wine-Staging's Patchset</flag>
</use>
+ <stabilize-allarches/>
<longdescription lang="en">
Allows for any variant of Wine, regardless of slotting to fulfill the dependencies
traditionally fulfilled by the non-slotted, pre-variant, app-emulation/wine.
diff --git a/virtual/wine/wine-0-r5.ebuild b/virtual/wine/wine-0-r10.ebuild
index ac3dcae4f7fd..ec2d32f55736 100644
--- a/virtual/wine/wine-0-r5.ebuild
+++ b/virtual/wine/wine-0-r10.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
SLOT="0"
-KEYWORDS="amd64 x86 ~x86-fbsd"
-IUSE="+abi_x86_32 +abi_x86_64 d3d9 staging"
-
+KEYWORDS="amd64 x86"
+IUSE="+abi_x86_32 +abi_x86_64 proton staging"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
# Note, the ordering here is intentional, to take advantage of the short-circuit
@@ -16,18 +15,10 @@ REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
# behind this is that some USE flags may pull in 3rd-party patchsets, so default
# of vanilla prevents that.
RDEPEND="
- staging? ( || (
- app-emulation/wine-staging[staging]
- app-emulation/wine-any[staging]
- ) )
- d3d9? ( || (
- app-emulation/wine-d3d9[d3d9]
- app-emulation/wine-any[d3d9]
- ) )
+ proton? ( app-emulation/wine-proton )
+ staging? ( app-emulation/wine-staging[staging(+)] )
|| (
app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
+ app-emulation/wine-proton[abi_x86_32=,abi_x86_64=]
app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
- app-emulation/wine-d3d9[abi_x86_32=,abi_x86_64=]
- app-emulation/wine-any[abi_x86_32=,abi_x86_64=]
- )
- !app-emulation/wine:0"
+ )"
diff --git a/virtual/wine/wine-0-r6.ebuild b/virtual/wine/wine-0-r6.ebuild
deleted file mode 100644
index 5371654fca77..000000000000
--- a/virtual/wine/wine-0-r6.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Virtual for Wine that supports multiple variants and slotting"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd"
-IUSE="+abi_x86_32 +abi_x86_64 d3d9 staging"
-
-REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
-
-# Note, the ordering here is intentional, to take advantage of the short-circuit
-# logic of portage, to enforce wine-vanilla as default for new users. The idea
-# behind this is that some USE flags may pull in 3rd-party patchsets, so default
-# of vanilla prevents that.
-RDEPEND="
- staging? ( || (
- app-emulation/wine-staging[staging]
- app-emulation/wine-any[staging]
- ) )
- d3d9? ( || (
- app-emulation/wine-d3d9[d3d9]
- app-emulation/wine-any[d3d9]
- ) )
- || (
- app-emulation/wine-vanilla[abi_x86_32=,abi_x86_64=]
- app-emulation/wine-staging[abi_x86_32=,abi_x86_64=]
- app-emulation/wine-d3d9[abi_x86_32=,abi_x86_64=]
- app-emulation/wine-any[abi_x86_32=,abi_x86_64=]
- )
- !app-emulation/wine:0"