summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/nanoc/Manifest1
-rw-r--r--www-apps/nanoc/nanoc-4.11.2.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/www-apps/nanoc/Manifest b/www-apps/nanoc/Manifest
index 11bfa7b27fa7..090997c22688 100644
--- a/www-apps/nanoc/Manifest
+++ b/www-apps/nanoc/Manifest
@@ -1,2 +1,3 @@
DIST nanoc-4.10.4.tar.gz 290367 BLAKE2B 0b5cf03938af1f971fccddb6bed4fa6b67da3aaf93cb7666c52e3ff8fc524f17ff10bf1a60ccf7f7b59f840d4c445ef57677349f5b83bc55e754e7078ac4b8d9 SHA512 5446e351906b5b6bbe5c9059dab86490d5deef5e1197adf5827fe201f2932d5cf79c65bfd9d9370ce57c35d965e013098d39d53fa96db8b4d1c6017977683ea2
DIST nanoc-4.11.0.tar.gz 291654 BLAKE2B ab88bf36b472106f356ae67782dac61f691e0d64646f410ae0cceca7a9df11689dd7a011bf58a773d6b35956f0092deac4db43bb8663d66463b72e10da27c658 SHA512 357345c9247465bd470bf6c71ea2b16e3415680fad6a4d4ee755eeb3a1443664590753003a5de0a740ffcfbaf93049c2c12c1f22de052f4d6efc2382430a4e08
+DIST nanoc-4.11.2.tar.gz 302927 BLAKE2B 206142cc13468c3456dfd141bb031791c3d6aa31b81cca04493519e8b44d7bc82d6837d266a0edecc58c0e635cee7428bfdf0d5428de7d5e6fb6eacebb09d45e SHA512 842703e5218c06e817ce188458ee0e9267467b92219dd566fda9d58cd21ec9842bbc011b8f2faa7854caf39af1379c2eae16a3e3b73c53f2c8af6b8851c7c8b9
diff --git a/www-apps/nanoc/nanoc-4.11.2.ebuild b/www-apps/nanoc/nanoc-4.11.2.ebuild
new file mode 100644
index 000000000000..02aaf44b073f
--- /dev/null
+++ b/www-apps/nanoc/nanoc-4.11.2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.md"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="nanoc is a simple but very flexible static site generator written in Ruby"
+HOMEPAGE="https://nanoc.ws/"
+SRC_URI="https://github.com/nanoc/nanoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE="${IUSE} minimal"
+
+DEPEND+="test? ( app-text/asciidoc app-text/highlight )"
+
+RUBY_S="${P}/nanoc"
+
+ruby_add_rdepend "!minimal? (
+ dev-ruby/mime-types:*
+ dev-ruby/rack:*
+ www-servers/adsf
+)
+ >=dev-ruby/addressable-2.5
+ >=dev-ruby/cri-2.15:0
+ ~www-apps/nanoc-core-${PV}
+ >=dev-ruby/parallel-1.12:1
+ >=dev-ruby/slow_enumerator_tools-1.1.0:1
+ >=dev-ruby/tomlrb-1.2:1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rspec:3
+ dev-ruby/asciidoctor
+ dev-ruby/fuubar
+ dev-ruby/haml
+ dev-ruby/maruku
+ >=dev-ruby/mocha-0.13
+ dev-ruby/minitest
+ dev-ruby/mustache
+ dev-ruby/pry
+ dev-ruby/rdoc
+ dev-ruby/rouge:2
+ dev-ruby/rubypants
+ dev-ruby/systemu
+ dev-ruby/timecop
+ dev-ruby/vcr
+ dev-ruby/webmock
+ dev-ruby/yard
+)
+doc? (
+ dev-ruby/kramdown
+ dev-ruby/rdiscount
+ dev-ruby/yard
+)"
+
+all_ruby_prepare() {
+ # Avoid unneeded development dependencies
+ sed -i -e '/simplecov/,/SimpleCov.formatter/ s:^:#:' test/helper.rb || die
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/codecov/I s:^:#:' ../common/spec/spec_helper_head_core.rb || die
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '/rubocop/ s:^:#:' Rakefile || die
+
+ echo "-r ./spec/spec_helper.rb" > .rspec || die
+
+ # Avoid tests requiring a network connection
+ rm -f test/checking/checks/test_{css,html}.rb || die
+
+ # Avoid tests for unpackaged dependencies
+ rm spec/nanoc/deploying/fog_spec.rb \
+ spec/nanoc/filters/less_spec.rb \
+ test/filters/test_{markaby,rainpress}.rb || die
+
+ # Avoid non-fatal failing tests due to specifics in the environment
+ sed -i -e '145askip "gentoo"' spec/nanoc/cli/error_handler_spec.rb || die
+ sed -i -e '/does not crash when output dir does not exist and/askip "gentoo"' spec/nanoc/cli/commands/view_spec.rb || die
+ sed -i -e '/watches with --watch/askip "gentoo"' spec/nanoc/cli/commands/compile_spec.rb || die
+ sed -i -e '124askip "ordering issues"' -e '168askip "ordering issues"' spec/nanoc/data_sources/filesystem_spec.rb || die
+}
+
+each_ruby_test() {
+ RUBYLIB="${S}/lib" ${RUBY} -S rake spec test_all || die
+}