summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/google-chrome-beta/google-chrome-beta-58.0.3029.68.ebuild')
-rw-r--r--www-client/google-chrome-beta/google-chrome-beta-58.0.3029.68.ebuild154
1 files changed, 154 insertions, 0 deletions
diff --git a/www-client/google-chrome-beta/google-chrome-beta-58.0.3029.68.ebuild b/www-client/google-chrome-beta/google-chrome-beta-58.0.3029.68.ebuild
new file mode 100644
index 000000000000..ad534ab13d7f
--- /dev/null
+++ b/www-client/google-chrome-beta/google-chrome-beta-58.0.3029.68.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+CHROMIUM_LANGS="am ar bg bn ca cs da de el en-GB es es-419 et fa fi fil fr gu he
+ hi hr hu id it ja kn ko lt lv ml mr ms nb nl pl pt-BR pt-PT ro ru sk sl sr
+ sv sw ta te th tr uk vi zh-CN zh-TW"
+
+inherit readme.gentoo-r1 chromium-2 eutils gnome2-utils pax-utils unpacker xdg-utils
+
+DESCRIPTION="The web browser from Google"
+HOMEPAGE="https://www.google.com/chrome"
+
+if [[ ${PN} == google-chrome ]]; then
+ MY_PN=${PN}-stable
+else
+ MY_PN=${PN}
+fi
+
+MY_P="${MY_PN}_${PV}-1"
+
+SRC_URI="https://dl.google.com/linux/chrome/deb/pool/main/g/${MY_PN}/${MY_P}_amd64.deb"
+
+LICENSE="google-chrome"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="+plugins"
+RESTRICT="bindist mirror strip"
+
+DEPEND=""
+RDEPEND="
+ app-arch/bzip2
+ app-misc/ca-certificates
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gconf:2
+ media-libs/alsa-lib
+ media-libs/fontconfig
+ media-libs/freetype:2
+ net-print/cups
+ sys-apps/dbus
+ sys-libs/libcap
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ >=x11-libs/libX11-1.5.0
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXScrnSaver
+ x11-libs/libXtst
+ x11-libs/pango
+ x11-misc/xdg-utils
+"
+
+QA_PREBUILT="*"
+QA_DESKTOP_FILE="usr/share/applications/google-chrome.*\\.desktop"
+S=${WORKDIR}
+CHROME_HOME="opt/google/chrome${PN#google-chrome}"
+
+DISABLE_AUTOFORMATTING="yes"
+DOC_CONTENTS="
+Some web pages may require additional fonts to display properly.
+Try installing some of the following packages if some characters
+are not displayed properly:
+- media-fonts/arphicfonts
+- media-fonts/bitstream-cyberbit
+- media-fonts/droid
+- media-fonts/ipamonafont
+- media-fonts/ja-ipafonts
+- media-fonts/takao-fonts
+- media-fonts/wqy-microhei
+- media-fonts/wqy-zenhei
+
+Depending on your desktop environment, you may need
+to install additional packages to get icons on the Downloads page.
+
+For KDE, the required package is kde-frameworks/oxygen-icons.
+
+For other desktop environments, try one of the following:
+- x11-themes/gnome-icon-theme
+- x11-themes/tango-icon-theme
+
+Please notice the bundled flash player (PepperFlash).
+You can (de)activate all flash plugins via chrome://plugins
+"
+
+pkg_nofetch() {
+ eerror "Please wait 24 hours and sync your tree before reporting a bug for google-chrome fetch failures."
+}
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "google-chrome only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ unpacker
+
+ rm -r etc usr/share/menu || die
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+
+ pushd "${CHROME_HOME}/locales" > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ if use plugins ; then
+ local plugins="--extra-plugin-dir=/usr/$(get_libdir)/nsbrowser/plugins"
+ sed -e "/^exec/ i set -- \"${plugins}\" \"\$@\"" \
+ -i "${CHROME_HOME}/${PN}" || die
+ fi
+
+ local size
+ for size in 16 22 24 32 48 64 128 256 ; do
+ newicon -s ${size} "${CHROME_HOME}/product_logo_${size}.png" ${PN}.png
+ done
+
+ pax-mark m "${CHROME_HOME}/chrome"
+
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ readme.gentoo_print_elog
+}