summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/adobe-flash')
-rw-r--r--www-plugins/adobe-flash/Manifest4
-rw-r--r--www-plugins/adobe-flash/adobe-flash-29.0.0.140.ebuild140
2 files changed, 144 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/Manifest b/www-plugins/adobe-flash/Manifest
index 15720ecd342b..037c2abc8f51 100644
--- a/www-plugins/adobe-flash/Manifest
+++ b/www-plugins/adobe-flash/Manifest
@@ -2,3 +2,7 @@ DIST adobe-flash-29.0.0.113-npapi.i386.tar.gz 8513691 BLAKE2B 235fd2faf3b7c5d9dd
DIST adobe-flash-29.0.0.113-npapi.x86_64.tar.gz 9031223 BLAKE2B 28968fd8e3a6a84ad88e09a17a1815d77fe157f9185c5329b3e2b67444f8a24fbf2f9ea5f2e62ece59e42c57a90cd82ecab5ac667146d83bae3e005d3dccd6cb SHA512 6d7a62d9cea4a2ca55351656ee8f28cc4f26488bb34d16fd9ea5ac2f6c871d3abe7b9c880b65c1680361d7b3848d8f827e2fc89a8e06214d68461f8b63317d0f
DIST adobe-flash-29.0.0.113-ppapi.i386.tar.gz 8547827 BLAKE2B bf630bf5ab10428c8e6bb5daf18263808d40c059407edeca870479797209492e745831300171fedbadaa2a6edecc8d22872ceb8e90cfef1dc8bb757eac5c049f SHA512 2394136affe23208471c5ddc1c147be69c98af9ea53e0d2c0e5511aa5fcdb61a931fe1919a858f5f20f497613188a835656568a7129442c517f8b94074650f3f
DIST adobe-flash-29.0.0.113-ppapi.x86_64.tar.gz 9464970 BLAKE2B accd90b0be5bcf975f2bcef379f201e97e96ec707660ad06343d0c9a25ac229795669a8652304c24c72584700f9041af37b48fea970363b026fa288a7ced715a SHA512 95e67c08a8bc27ed3fdb8f42d8fe466755334827bfd8a42dd0be99bfb21ed0f1f3e1d6ead655cf5e6d8d8767f201aa3134f0691eb285d8beeee6cd7f2a812ac4
+DIST adobe-flash-29.0.0.140-npapi.i386.tar.gz 8520298 BLAKE2B 81fbfa2a82702314f06196ca346dbfe768c4c0ae6512c012fb1b5c2323385c58d64ca87a3c6f7745c2840832c7e0e9e7fe500c1974786b7f835f454aac64b1b8 SHA512 0b478fdc4d606bfa3b1a379dd5d84aaee9ac1fe6f66acd2d79e787f8590f5140c1c6c48c26e3679375910f197945728625944963f1081a1e324b49add2a6d6dc
+DIST adobe-flash-29.0.0.140-npapi.x86_64.tar.gz 9036010 BLAKE2B d1c25e93740cf53f0d551ba859cb4a23ba61fb2816e30d7f8ce503d11cb56ad8058e1bc2259b6bb2986ff751b45b2c2f2a8d63fbf6503e64df1342b73e2976a7 SHA512 acd2ea77a8e7baf4dc473f6301e7ca3df633fd0e61815b99fa16204b574409190811daeb31a936fdc8187f1a7da4e5014ab1a95572b6fb3d2b2276498fa8bcc8
+DIST adobe-flash-29.0.0.140-ppapi.i386.tar.gz 8554989 BLAKE2B 7c662ce66f6d0079f673b28691afea5cca6276a934b851d0d91fcbc4e81320eedf8ee4bf6bf909a8909a76c83a3e6839cb3d521813891f9a7675f69c17da79f1 SHA512 979fc4d626449e0caa350fd8d8ec2a023e72089aaa9ce1a828e1bb37b0bb1431653642c30e0aaef30df8a0d7c8633b232d7f6525f6dc8df2a708f8af7c46e1b9
+DIST adobe-flash-29.0.0.140-ppapi.x86_64.tar.gz 9471488 BLAKE2B 94d3a3fd549cf0f6e9358f153c665160ddc2e4366b92370f615fb328c422e990f9b9785218a0fe0ba998089f5bc3fd241bfd58dd40b210ba05aabc01bfba6602 SHA512 7af12d05a0043d67c6db71b0f4f3797330b4fa27da75877ee7ac9371f80f67131fa499f5cb4f271b80e30cd02845d7ab40a68c7e8dffa0a769f89b1d9b393cc2
diff --git a/www-plugins/adobe-flash/adobe-flash-29.0.0.140.ebuild b/www-plugins/adobe-flash/adobe-flash-29.0.0.140.ebuild
new file mode 100644
index 000000000000..edde28781c17
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-29.0.0.140.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils nsplugins multilib multilib-minimal
+
+DESCRIPTION="Adobe Flash Player"
+HOMEPAGE="
+ https://www.adobe.com/products/flashplayer.html
+ https://get.adobe.com/flashplayer/
+ https://helpx.adobe.com/security/products/flash-player.html
+"
+
+AF_URI="https://fpdownload.adobe.com/pub/flashplayer/pdc/${PV}"
+AF_NP_32_URI="${AF_URI}/flash_player_npapi_linux.i386.tar.gz -> ${P}-npapi.i386.tar.gz"
+AF_NP_64_URI="${AF_URI}/flash_player_npapi_linux.x86_64.tar.gz -> ${P}-npapi.x86_64.tar.gz"
+AF_PP_32_URI="${AF_URI}/flash_player_ppapi_linux.i386.tar.gz -> ${P}-ppapi.i386.tar.gz"
+AF_PP_64_URI="${AF_URI}/flash_player_ppapi_linux.x86_64.tar.gz -> ${P}-ppapi.x86_64.tar.gz"
+
+IUSE="+nsplugin +ppapi"
+REQUIRED_USE="
+ || ( nsplugin ppapi )
+"
+
+SRC_URI="
+ nsplugin? (
+ abi_x86_32? ( ${AF_NP_32_URI} )
+ abi_x86_64? ( ${AF_NP_64_URI} )
+ )
+ ppapi? (
+ abi_x86_32? ( ${AF_PP_32_URI} )
+ abi_x86_64? ( ${AF_PP_64_URI} )
+ )
+"
+SLOT="22"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-11.x"
+RESTRICT="strip mirror"
+
+NPAPI_RDEPEND="
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ >=sys-libs/glibc-2.4
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ !www-plugins/chrome-binary-plugins[flash(-)]
+ nsplugin? (
+ ${NPAPI_RDEPEND}
+ !www-plugins/adobe-flash:0
+ )
+"
+
+S="${WORKDIR}"
+
+# Ignore QA warnings in these closed-source binaries, since we can't fix them:
+QA_PREBUILT="usr/*"
+
+src_unpack() {
+ local files=( ${A} )
+
+ multilib_src_unpack() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ # we need to filter out the other archive(s)
+ local other_abi
+ [[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
+ unpack ${files[@]//*${other_abi}*/}
+ }
+
+ multilib_parallel_foreach_abi multilib_src_unpack
+}
+
+multilib_src_install() {
+ local pkglibdir=lib
+ [[ -d usr/lib64 ]] && pkglibdir=lib64
+
+ if use nsplugin; then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe libflashplayer.so
+
+ if multilib_is_native_abi; then
+ # No KDE applet, so allow the GTK utility to show up in KDE:
+ sed \
+ -i usr/share/applications/flash-player-properties.desktop \
+ -e "/^NotShowIn=KDE;/d" || die
+
+ # The userland 'flash-player-properties' standalone app:
+ dobin usr/bin/flash-player-properties
+
+ # Icon and .desktop for 'flash-player-properties'
+ insinto /usr/share
+ doins -r usr/share/{icons,applications}
+ dosym ../icons/hicolor/48x48/apps/flash-player-properties.png \
+ /usr/share/pixmaps/flash-player-properties.png
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+ fi
+
+ if use ppapi; then
+ exeinto /usr/$(get_libdir)/chromium/PepperFlash
+ doexe libpepflashplayer.so
+ insinto /usr/$(get_libdir)/chromium/PepperFlash
+ doins manifest.json
+
+ if multilib_is_native_abi; then
+ dodir /etc/chromium
+ sed "${FILESDIR}"/pepper-flash-r1 \
+ -e "s|@FP_LIBDIR@|$(get_libdir)|g" \
+ -e "s|@FP_PV@|${PV}|g" \
+ > "${D}"/etc/chromium/pepper-flash \
+ || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}