summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins/adobe-flash')
-rw-r--r--www-plugins/adobe-flash/Manifest4
-rw-r--r--www-plugins/adobe-flash/adobe-flash-28.0.0.161.ebuild140
2 files changed, 144 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/Manifest b/www-plugins/adobe-flash/Manifest
index a4427b7d1beb..a42979a5748f 100644
--- a/www-plugins/adobe-flash/Manifest
+++ b/www-plugins/adobe-flash/Manifest
@@ -2,3 +2,7 @@ DIST adobe-flash-28.0.0.137-npapi.i386.tar.gz 8511300 BLAKE2B e1396927c13af726ec
DIST adobe-flash-28.0.0.137-npapi.x86_64.tar.gz 9027156 BLAKE2B 136f75ec96466c60895e38d8a4b36cab7f872d110459daac104d90384384c65ce05656ba01218d456917fd2fff2cb710a03b2374bd2d75c65a8e85cc37a24013 SHA512 07d0284296e4f6dbd8a7351da968cfdb4dff1885a997735b8e97f8c7a87c892241758cba376cd3b1ea059d26818111790fe1d3d665c4babaaeb7ae645a990a15
DIST adobe-flash-28.0.0.137-ppapi.i386.tar.gz 8547088 BLAKE2B 8b5964935b752e26809e35b44d87ce613a951714019ca9d9902c64fa22f0cf057bd57ed57b5ce56c8b16e1ab859401425c21c85c06c123ba6f23f65bec46fc01 SHA512 f5d9d344c4f6522f35dbcefbd786f6dabd701346688f4858a9feb3b683cfa79342c0f5f62c08cb53870278f717a405803186bba49c1091f5a23fe86b9bcf43b1
DIST adobe-flash-28.0.0.137-ppapi.x86_64.tar.gz 9463126 BLAKE2B 9fa28932aeaa4050282e202cb14adb83fc51d89ce1a36d5f7aa6b490069ad76827726ab0574580c351fe8f4ea755839c1549d94f4ffc3ca4663c3be9567eeb07 SHA512 9087b9197e0eeb8d71401246c7dd30bff9a571ce1bb07e30d99bda493b2da765a6929d13ec66a7e7ffb8614c58fcc2ed6556ed555c93adbeaa6e388e8d54e427
+DIST adobe-flash-28.0.0.161-npapi.i386.tar.gz 8513055 BLAKE2B fd016ff576f9da47abe9f9dac1a4397ba14713a136fae27d50b62751e460228a13b380386b97199ad386d76ef22bbf228ca67066ea610c3013ebc51c354e34a1 SHA512 f3bd5d31528eb412c29b0cf225da66c77d4e3626185be200741e7c6956f6b125a21dca2bc50252cd2d9f888dbf0d3b3634290076ab82dfa5d619f293fe1ed95a
+DIST adobe-flash-28.0.0.161-npapi.x86_64.tar.gz 9031862 BLAKE2B 5978479338450a6ff6df3415698da357a216e39f84c48a83e4544007846590c962a852c9e2c869b5603045c04e64e82ff39cb240b9361652f2a2932b6644a5da SHA512 1ee0eddc64bcd0456836296709e64dad29dd8f89589b1f7f9d685b52cdb2896ac6b4a11274362afec87732d9bd101d1e6927083515ad7243a64672a95cab3423
+DIST adobe-flash-28.0.0.161-ppapi.i386.tar.gz 8548252 BLAKE2B e8701fa13e014a1ef95acea828bb698c70357129f41d137013994535401d35ef1bb84da9128e8b8f045b272ec1e06837b7d2fb14fdd8d25f674a6694062fcf1e SHA512 5c3bdb3111d17e3b444ea6fd8a8a20aa764388c00d09964d90a770a523d655c85d0178051483dd31c1ae26b408327a43aae02c24569c1dad7d21eb5976c11451
+DIST adobe-flash-28.0.0.161-ppapi.x86_64.tar.gz 9466688 BLAKE2B 70a37f855e22028c8d29777a19ea3c6a839dc2d360a3390e8b8583c35d3efd7a12d263cfa62d38fdc52e174e69e4824bad5508bb08cf90ae67711ad99188facf SHA512 96b0b3db0b8c13e420b7a056777c8cbf00b98ea1e1d0e45dc718ca15925f04ccc62206494f1123fb5725bc76f569b3eee83888820868d1f18bcb7cdd7f621776
diff --git a/www-plugins/adobe-flash/adobe-flash-28.0.0.161.ebuild b/www-plugins/adobe-flash/adobe-flash-28.0.0.161.ebuild
new file mode 100644
index 000000000000..edde28781c17
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-28.0.0.161.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils nsplugins multilib multilib-minimal
+
+DESCRIPTION="Adobe Flash Player"
+HOMEPAGE="
+ https://www.adobe.com/products/flashplayer.html
+ https://get.adobe.com/flashplayer/
+ https://helpx.adobe.com/security/products/flash-player.html
+"
+
+AF_URI="https://fpdownload.adobe.com/pub/flashplayer/pdc/${PV}"
+AF_NP_32_URI="${AF_URI}/flash_player_npapi_linux.i386.tar.gz -> ${P}-npapi.i386.tar.gz"
+AF_NP_64_URI="${AF_URI}/flash_player_npapi_linux.x86_64.tar.gz -> ${P}-npapi.x86_64.tar.gz"
+AF_PP_32_URI="${AF_URI}/flash_player_ppapi_linux.i386.tar.gz -> ${P}-ppapi.i386.tar.gz"
+AF_PP_64_URI="${AF_URI}/flash_player_ppapi_linux.x86_64.tar.gz -> ${P}-ppapi.x86_64.tar.gz"
+
+IUSE="+nsplugin +ppapi"
+REQUIRED_USE="
+ || ( nsplugin ppapi )
+"
+
+SRC_URI="
+ nsplugin? (
+ abi_x86_32? ( ${AF_NP_32_URI} )
+ abi_x86_64? ( ${AF_NP_64_URI} )
+ )
+ ppapi? (
+ abi_x86_32? ( ${AF_PP_32_URI} )
+ abi_x86_64? ( ${AF_PP_64_URI} )
+ )
+"
+SLOT="22"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-11.x"
+RESTRICT="strip mirror"
+
+NPAPI_RDEPEND="
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ >=sys-libs/glibc-2.4
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ !www-plugins/chrome-binary-plugins[flash(-)]
+ nsplugin? (
+ ${NPAPI_RDEPEND}
+ !www-plugins/adobe-flash:0
+ )
+"
+
+S="${WORKDIR}"
+
+# Ignore QA warnings in these closed-source binaries, since we can't fix them:
+QA_PREBUILT="usr/*"
+
+src_unpack() {
+ local files=( ${A} )
+
+ multilib_src_unpack() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ # we need to filter out the other archive(s)
+ local other_abi
+ [[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
+ unpack ${files[@]//*${other_abi}*/}
+ }
+
+ multilib_parallel_foreach_abi multilib_src_unpack
+}
+
+multilib_src_install() {
+ local pkglibdir=lib
+ [[ -d usr/lib64 ]] && pkglibdir=lib64
+
+ if use nsplugin; then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe libflashplayer.so
+
+ if multilib_is_native_abi; then
+ # No KDE applet, so allow the GTK utility to show up in KDE:
+ sed \
+ -i usr/share/applications/flash-player-properties.desktop \
+ -e "/^NotShowIn=KDE;/d" || die
+
+ # The userland 'flash-player-properties' standalone app:
+ dobin usr/bin/flash-player-properties
+
+ # Icon and .desktop for 'flash-player-properties'
+ insinto /usr/share
+ doins -r usr/share/{icons,applications}
+ dosym ../icons/hicolor/48x48/apps/flash-player-properties.png \
+ /usr/share/pixmaps/flash-player-properties.png
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+ fi
+
+ if use ppapi; then
+ exeinto /usr/$(get_libdir)/chromium/PepperFlash
+ doexe libpepflashplayer.so
+ insinto /usr/$(get_libdir)/chromium/PepperFlash
+ doins manifest.json
+
+ if multilib_is_native_abi; then
+ dodir /etc/chromium
+ sed "${FILESDIR}"/pepper-flash-r1 \
+ -e "s|@FP_LIBDIR@|$(get_libdir)|g" \
+ -e "s|@FP_PV@|${PV}|g" \
+ > "${D}"/etc/chromium/pepper-flash \
+ || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}