summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-plugins')
-rw-r--r--www-plugins/adobe-flash/Manifest4
-rw-r--r--www-plugins/adobe-flash/adobe-flash-31.0.0.122.ebuild140
2 files changed, 144 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/Manifest b/www-plugins/adobe-flash/Manifest
index e0eeb467a03c..1ab8689151bc 100644
--- a/www-plugins/adobe-flash/Manifest
+++ b/www-plugins/adobe-flash/Manifest
@@ -2,3 +2,7 @@ DIST adobe-flash-31.0.0.108-npapi.i386.tar.gz 8529291 BLAKE2B ded98c85f55dbc9bc8
DIST adobe-flash-31.0.0.108-npapi.x86_64.tar.gz 9047129 BLAKE2B 11a3d90683442261ebb79fbc21bdcbf31b4369815c74a6460d7b59b01b7f0d8444143b540c7635c07aa3fd300feaceb1e3e6b1812d0c6b4f1b39f21cf5ee2a12 SHA512 6cf83b12002220aef393115b27e6b3e4bcd9901c3e6c782bbe2a0c2fbcee498454d34cecd6c629252b24c25966e2703ca9b5b193d14fcb0a3be39ebd38fd2a18
DIST adobe-flash-31.0.0.108-ppapi.i386.tar.gz 8561961 BLAKE2B 4917fb4188b1c12e077babdfa0def0148bbad95359a48fce9ec94d934341c00aae6e19879f4287058706992baa6a44b3047ef5997d8f18ea2456c0701f61cfae SHA512 4ddaaeaf2fe5768ffd8fd91b97021625f1f9472c58ec51e2e385113e90096e51563d04cca9d7fb1932e818ff3c6a6370ce95b356882e846407af00f58c41e3ff
DIST adobe-flash-31.0.0.108-ppapi.x86_64.tar.gz 9479466 BLAKE2B 13b8165081aa9e99f164406c23c4a816ad6f2e2ea235e0d8914626b6b70fedddcf641d1879a5b6ca4e41194cf424f877928bd2a93b408d8bb763d8d01c55c2eb SHA512 e4846fdd0301e7f4df811128c97bf782d34abde60c440e66335cdd99cc458a5ac120cc4f8ef7707f7383dbc89db3d9ecf46cbd39822f4f889b3e9664e61a1091
+DIST adobe-flash-31.0.0.122-npapi.i386.tar.gz 8529106 BLAKE2B 71984e263ec5fb1720288208371551a74a22a982832dc16b2da314fc1fc1ee1009faf36b2648e9ed52a6eb4b7a34a5ffef5af266e31daca0fc3049162cc6c4f9 SHA512 8383f15cf14528a9b3bbf15b880b530f15fbec18708ccbfce83bdd6ec6bef8b7b7fd8f8231dfa534e42d077ef7b5bf92627a6fcc14749abefca748b307680e4b
+DIST adobe-flash-31.0.0.122-npapi.x86_64.tar.gz 9044791 BLAKE2B 4f659381aeffd1a46e8a72cad7612c9b626ff0bf208492502c887a9bcd5beb9888bd8063265a81dd3b848fa97dedde327ab4563b262719fab7620912efe2c1e6 SHA512 c8f27ef630ac6797c0879b444499e954ba5e46564a9d35842134fb963cf7866bbc1badbc773ccdce928c158c716d63d91b79e47b10f8388c97493dd16bd66911
+DIST adobe-flash-31.0.0.122-ppapi.i386.tar.gz 8563099 BLAKE2B 0951b14ed7a3c8ea7dbb7ab2de93521435a164a4358f20084cb3e407fb45d19561fd17871553bb2a39da9caf7dec17388d825b51ccafa8184e6fbfd006c328e0 SHA512 fc2efd870a6a2fabd53b1c6d095fd0ffc6c9e1d05a13ebaec93ea31bc84e022e8b54e8c2194a42a54dd3258c8d2fb378fa14205acb3c4a876b07c48e40c18d96
+DIST adobe-flash-31.0.0.122-ppapi.x86_64.tar.gz 9482137 BLAKE2B 25585e857de26917880aa09289b7ea2e3b0191f958495d2523461ffd55869a67808c604b9bd5d80c9ea4326df9b72a5a4a3c47a8f2cb32071093df9a7f7ea673 SHA512 64e18f58ce7abda62aa098c47c260226f67d78e17698175629f2777fbcde84b2bd88e80b6247af34bcfe6bed3a558e767b43f45fdf2164cb974d59e70751a4fc
diff --git a/www-plugins/adobe-flash/adobe-flash-31.0.0.122.ebuild b/www-plugins/adobe-flash/adobe-flash-31.0.0.122.ebuild
new file mode 100644
index 000000000000..b4fe619358d4
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-31.0.0.122.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils nsplugins multilib multilib-minimal
+
+DESCRIPTION="Adobe Flash Player"
+HOMEPAGE="
+ https://www.adobe.com/products/flashplayer.html
+ https://get.adobe.com/flashplayer/
+ https://helpx.adobe.com/security/products/flash-player.html
+"
+
+AF_URI="https://fpdownload.adobe.com/pub/flashplayer/pdc/${PV}"
+AF_NP_32_URI="${AF_URI}/flash_player_npapi_linux.i386.tar.gz -> ${P}-npapi.i386.tar.gz"
+AF_NP_64_URI="${AF_URI}/flash_player_npapi_linux.x86_64.tar.gz -> ${P}-npapi.x86_64.tar.gz"
+AF_PP_32_URI="${AF_URI}/flash_player_ppapi_linux.i386.tar.gz -> ${P}-ppapi.i386.tar.gz"
+AF_PP_64_URI="${AF_URI}/flash_player_ppapi_linux.x86_64.tar.gz -> ${P}-ppapi.x86_64.tar.gz"
+
+IUSE="+nsplugin +ppapi"
+REQUIRED_USE="
+ || ( nsplugin ppapi )
+"
+
+SRC_URI="
+ nsplugin? (
+ abi_x86_32? ( ${AF_NP_32_URI} )
+ abi_x86_64? ( ${AF_NP_64_URI} )
+ )
+ ppapi? (
+ abi_x86_32? ( ${AF_PP_32_URI} )
+ abi_x86_64? ( ${AF_PP_64_URI} )
+ )
+"
+SLOT="22"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-11.x"
+RESTRICT="strip mirror"
+
+NPAPI_RDEPEND="
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ >=sys-libs/glibc-2.4
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ !www-plugins/chrome-binary-plugins[flash(-)]
+ nsplugin? (
+ ${NPAPI_RDEPEND}
+ !www-plugins/adobe-flash:0
+ )
+"
+
+S="${WORKDIR}"
+
+# Ignore QA warnings in these closed-source binaries, since we can't fix them:
+QA_PREBUILT="usr/*"
+
+src_unpack() {
+ local files=( ${A} )
+
+ multilib_src_unpack() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ # we need to filter out the other archive(s)
+ local other_abi
+ [[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
+ unpack ${files[@]//*${other_abi}*/}
+ }
+
+ multilib_parallel_foreach_abi multilib_src_unpack
+}
+
+multilib_src_install() {
+ local pkglibdir=lib
+ [[ -d usr/lib64 ]] && pkglibdir=lib64
+
+ if use nsplugin; then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe libflashplayer.so
+
+ if multilib_is_native_abi; then
+ # No KDE applet, so allow the GTK utility to show up in KDE:
+ sed \
+ -i usr/share/applications/flash-player-properties.desktop \
+ -e "/^NotShowIn=KDE;/d" || die
+
+ # The userland 'flash-player-properties' standalone app:
+ dobin usr/bin/flash-player-properties
+
+ # Icon and .desktop for 'flash-player-properties'
+ insinto /usr/share
+ doins -r usr/share/{icons,applications}
+ dosym ../icons/hicolor/48x48/apps/flash-player-properties.png \
+ /usr/share/pixmaps/flash-player-properties.png
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+ fi
+
+ if use ppapi; then
+ exeinto /usr/$(get_libdir)/chromium/PepperFlash
+ doexe libpepflashplayer.so
+ insinto /usr/$(get_libdir)/chromium/PepperFlash
+ doins manifest.json
+
+ if multilib_is_native_abi; then
+ dodir /etc/chromium
+ sed "${FILESDIR}"/pepper-flash-r1 \
+ -e "s|@FP_LIBDIR@|$(get_libdir)|g" \
+ -e "s|@FP_PV@|${PV}|g" \
+ > "${D}"/etc/chromium/pepper-flash \
+ || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}