summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/gunicorn')
-rw-r--r--www-servers/gunicorn/Manifest1
-rw-r--r--www-servers/gunicorn/gunicorn-20.1.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-servers/gunicorn/Manifest b/www-servers/gunicorn/Manifest
index 60da7a8e397c..495510200856 100644
--- a/www-servers/gunicorn/Manifest
+++ b/www-servers/gunicorn/Manifest
@@ -1 +1,2 @@
DIST gunicorn-20.0.4.tar.gz 373841 BLAKE2B d6f0b5b901697ebc6ee987af5766174a845de8bfad03ce95638ed087b92175e9b2f0e9a49fda70f8f9c6fdc15e1ef1a431c069270af068fb29780abcedf63fc3 SHA512 706620f165e36c178a6d3e65f51a9bb7746abd40dfc7c0f1b3b523771be953dd03b36111f192407aef474ad44afdffd11b6502e51376d11465ffac2255822d5e
+DIST gunicorn-20.1.0.tar.gz 354960 BLAKE2B bae414a8da7a4dbdf79e0b46f517138534521a1a8544f4ea2e1e27e6778d2f6ad8d6a8af02590fedad47d305acdea53f1cdbc4deeda3619fc4a5ffef0932bea1 SHA512 4fd905f62adc30e044cf2a56a1a77e14bc633258267d6bfbd4f6a68494f93f377e9fb9ed94fab7f11f9d7813857a680974a88c4b6bf97d4f1b74792a81810111
diff --git a/www-servers/gunicorn/gunicorn-20.1.0.ebuild b/www-servers/gunicorn/gunicorn-20.1.0.ebuild
new file mode 100644
index 000000000000..7905e095b6ea
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-20.1.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="https://gunicorn.org https://pypi.org/project/gunicorn https://github.com/benoitc/gunicorn"
+# Not on PyPI yet as of 2021-03-15
+SRC_URI="https://github.com/benoitc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT PSF-2 doc? ( BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst )
+
+distutils_enable_sphinx 'docs/source' --no-autodoc
+distutils_enable_tests pytest
+
+src_prepare() {
+ # These fail if respective optional packages have not been installed
+ rm -f tests/workers/test_g{eventlet,gevent}.py
+
+ sed -e 's:--cov=gunicorn --cov-report=xml::' -i setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/_build/html/. )
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "Note that alternative worker types need additional packages to be installed:"
+ optfeature "eventlet-based greenlets workers" "dev-python/eventlet"
+ optfeature "gevent-based greenlets workers" "dev-python/gevent"
+ elog
+}