summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/files/http_uploadprogress-issue_50-r1.patch31
-rw-r--r--www-servers/nginx/files/http_uploadprogress-issue_50.patch32
-rw-r--r--www-servers/nginx/nginx-1.10.2-r1.ebuild2
-rw-r--r--www-servers/nginx/nginx-1.11.5-r1.ebuild2
4 files changed, 33 insertions, 34 deletions
diff --git a/www-servers/nginx/files/http_uploadprogress-issue_50-r1.patch b/www-servers/nginx/files/http_uploadprogress-issue_50-r1.patch
new file mode 100644
index 000000000000..42cbd779a8cb
--- /dev/null
+++ b/www-servers/nginx/files/http_uploadprogress-issue_50-r1.patch
@@ -0,0 +1,31 @@
+From dd138546b16a01e9c09613d02211373baf1cac02 Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@whissi.de>
+Date: Thu, 20 Oct 2016 03:09:37 +0200
+Subject: [PATCH] config: Fix ngx_module_type
+
+Since commit 37182ce2f3b6 the module was not present in static builds
+because due to an invalid "ngx_module_type" the module was not added to
+objs/ngx_modules.c.
+
+This commit will fix the problem by setting the correct module type
+"HTTP_FILTER" [Link 1].
+
+Link 1: https://www.nginx.com/resources/wiki/extending/new_config/#key-ngx_module_type
+Gentoo-Bug: https://bugs.gentoo.org/593450
+Fixes: https://github.com/masterzen/nginx-upload-progress-module/issues/50
+---
+ config | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/config b/config
+index 364af8c..5f4ade1 100644
+--- a/config
++++ b/config
+@@ -1,6 +1,6 @@
+ ngx_addon_name=ngx_http_uploadprogress_module
+ if test -n "$ngx_module_link"; then
+- ngx_module_type=FILTER
++ ngx_module_type=HTTP_FILTER
+ ngx_module_name=ngx_http_uploadprogress_module
+ ngx_module_srcs="$ngx_addon_dir/ngx_http_uploadprogress_module.c"
+
diff --git a/www-servers/nginx/files/http_uploadprogress-issue_50.patch b/www-servers/nginx/files/http_uploadprogress-issue_50.patch
deleted file mode 100644
index 3347c5b54708..000000000000
--- a/www-servers/nginx/files/http_uploadprogress-issue_50.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From edd7e026fa992f58b04ea9d00b56239f37b3e320 Mon Sep 17 00:00:00 2001
-From: Thomas Deutschmann <whissi@whissi.de>
-Date: Wed, 19 Oct 2016 15:05:27 +0200
-Subject: [PATCH] config: Only build as dynamic module when really requested
-
-Since commit 37182ce2f3b6 the module was always build as dynamic module.
-Probably because following a bad skeleton [1].
-
-With this change we will only build a dynamic module when requested. Otherwise
-we will fall back to static build.
-
-Link: https://trac.nginx.org/nginx/ticket/1115
-Gentoo-Bug: https://bugs.gentoo.org/593450
-Fixes: https://github.com/masterzen/nginx-upload-progress-module/issues/50
----
- config | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/config b/config
-index 364af8c..d704460 100644
---- a/config
-+++ b/config
-@@ -1,5 +1,5 @@
- ngx_addon_name=ngx_http_uploadprogress_module
--if test -n "$ngx_module_link"; then
-+if [ $ngx_module_link = DYNAMIC ] ; then
- ngx_module_type=FILTER
- ngx_module_name=ngx_http_uploadprogress_module
- ngx_module_srcs="$ngx_addon_dir/ngx_http_uploadprogress_module.c"
---
-2.10.1
-
diff --git a/www-servers/nginx/nginx-1.10.2-r1.ebuild b/www-servers/nginx/nginx-1.10.2-r1.ebuild
index c649333d465a..8690da9c9eb4 100644
--- a/www-servers/nginx/nginx-1.10.2-r1.ebuild
+++ b/www-servers/nginx/nginx-1.10.2-r1.ebuild
@@ -354,7 +354,7 @@ src_prepare() {
if use nginx_modules_http_upload_progress; then
cd "${HTTP_UPLOAD_PROGRESS_MODULE_WD}" || die
- eapply "${FILESDIR}"/http_uploadprogress-issue_50.patch
+ eapply "${FILESDIR}"/http_uploadprogress-issue_50-r1.patch
cd "${S}" || die
fi
diff --git a/www-servers/nginx/nginx-1.11.5-r1.ebuild b/www-servers/nginx/nginx-1.11.5-r1.ebuild
index 46c24d304a73..5aae3ae8fd0b 100644
--- a/www-servers/nginx/nginx-1.11.5-r1.ebuild
+++ b/www-servers/nginx/nginx-1.11.5-r1.ebuild
@@ -362,7 +362,7 @@ src_prepare() {
if use nginx_modules_http_upload_progress; then
cd "${HTTP_UPLOAD_PROGRESS_MODULE_WD}" || die
- eapply "${FILESDIR}"/http_uploadprogress-issue_50.patch
+ eapply "${FILESDIR}"/http_uploadprogress-issue_50-r1.patch
cd "${S}" || die
fi