summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/monkeyd/Manifest1
-rw-r--r--www-servers/monkeyd/monkeyd-1.6.8.ebuild141
2 files changed, 0 insertions, 142 deletions
diff --git a/www-servers/monkeyd/Manifest b/www-servers/monkeyd/Manifest
index 2a10383bcdf0..701c58a8e75e 100644
--- a/www-servers/monkeyd/Manifest
+++ b/www-servers/monkeyd/Manifest
@@ -1,3 +1,2 @@
DIST monkey-1.5.6.tar.gz 902636 SHA256 7c3d845306aa74ee6effd7ab6169d16ac4e6450e564954d0d0baa2d1e9be1a22 SHA512 4c7c627cb047252252b22da5fba179a21fb5b8dc6280b96307af52757ad049d24b0daaaea51dca4f0429af5e6499c239f6b62a03654cc9e7ad98ae8f5149b64c WHIRLPOOL aba1a928023fc67224f254182eb9707c6594c7092d9ff98ecfa297c91d5c61f79235e7467192b5d46ac114ae67a3cee98e06704721348a40ee825755ab39d9a1
-DIST monkey-1.6.8.tar.gz 1967478 SHA256 936aa276d11dea77cda2703eb5d1b89ede1cf8d44440e1ec029cafb10effb3cf SHA512 44d3c9785190849e50ffc28168a41939ddb9fa62e7c0ead26fa67ff78eae1b3855a9729b3de520b53d629607b456e9fa6fe31b7d0b0036c514c1d13296b7e8db WHIRLPOOL 227559f6e625ca78690072aff0eddfcbdad2aba11b395c2636b58ce3329b657324975631be0392e4e92004fb0233bda3384fb080b2381035bf7d743d198ef4bc
DIST monkey-1.6.9.tar.gz 1972040 SHA256 f1122e89cda627123286542b0a18fcaa131cbe9d4f5dd897d9455157289148fb SHA512 3540a17fffe57a9d4b88b6243c634dcf6a27ed894ae2a0d5d42a4881221a9d59ae67d4c7fcf087535360d20ccdadab16947cf3a7dc6d4e864d487f598eb0ba62 WHIRLPOOL c0af688a0a9d8d82a6dc405a79640738ebd62fe1de8a0aad715c1356c73a499ff5854f2a16d69e9a1022bfd02ca04dc17163011a27e53b438ca0e32c9b824f2b
diff --git a/www-servers/monkeyd/monkeyd-1.6.8.ebuild b/www-servers/monkeyd/monkeyd-1.6.8.ebuild
deleted file mode 100644
index b97936f30923..000000000000
--- a/www-servers/monkeyd/monkeyd-1.6.8.ebuild
+++ /dev/null
@@ -1,141 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="A small, fast, and scalable web server"
-HOMEPAGE="http://www.monkey-project.com/"
-MY_P="${PN/d}-${PV}"
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/monkey/monkey.git"
- inherit git-2
- KEYWORDS="arm"
-else
- SRC_URI="http://monkey-project.com/releases/${PV:0:3}/${MY_P}.tar.gz"
- KEYWORDS="~amd64 arm ~mips ~ppc ~ppc64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-
-# jemalloc is also off until we figure out how to work CMakeLists.txt magic.
-#IUSE="cgi -debug fastcgi jemalloc php static-plugins ${PLUGINS}"
-
-PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
-IUSE="cgi -debug fastcgi php static-plugins ${PLUGINS}"
-
-# uclibc is often compiled without backtrace info so we should
-# force this off. If someone complains, consider relaxing it.
-REQUIRED_USE="
- monkeyd_plugins_tls? ( !static-plugins )
- elibc_uclibc? ( !debug )
- cgi? ( php )"
-
-#DEPEND="jemalloc? ( >=dev-libs/jemalloc-3.3.1 )"
-DEPEND="
- dev-util/cmake
- monkeyd_plugins_tls? ( net-libs/mbedtls:= )"
-RDEPEND="
- php? ( dev-lang/php )
- cgi? ( dev-lang/php[cgi] )"
-
-S="${WORKDIR}/${MY_P}"
-
-WEBROOT="/var/www/localhost"
-
-pkg_setup() {
- if use debug; then
- ewarn
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn "Do not use debug in production!"
- ewarn "\033[1;33m**************************************************\033[00m"
- ewarn
- fi
-}
-
-src_prepare() {
- # Unconditionally get rid of the bundled jemalloc
- rm -rf "${S}"/deps
- epatch "${FILESDIR}"/${PN}-1.6.8-system-mbedtls.patch
-}
-
-src_configure() {
- local myconf=""
-
- use elibc_uclibc && myconf+=" --uclib-mode"
- use elibc_musl && myconf+=" --musl-mode"
-
- #use jemalloc || myconf+=" --malloc-libc"
- myconf+=" --malloc-libc"
-
- if use debug; then
- myconf+=" --debug --trace"
- else
- myconf+=" --no-backtrace"
- fi
-
- local enable_plugins=""
- local disable_plugins=""
- # We use 'cgi' and 'fastcgi' because they are global flags
- # instead of the corresponding monkeyd_plugins_*
- use cgi && enable_plugins+="cgi," || disable_plugins+="cgi,"
- use fastcgi && enable_plugins+="fastcgi," || disable_plugins+="fastcgi,"
- # For the rest, we scan the monkeyd_plugins_* and parse out the plugin name.
- local p
- for p in ${PLUGINS}; do
- pp=${p/+/}
- cp=${pp/monkeyd_plugins_/}
- use $pp && enable_plugins+="${cp}," || disable_plugins+="${cp},"
- done
- myconf+=" --enable-plugins=${enable_plugins%,} --disable-plugins=${disable_plugins%,}"
- if use static-plugins; then
- myconf+=" --static-plugins=${enable_plugins%,}"
- fi
-
- # For O_CLOEXEC which is guarded by _GNU_SOURCE in uClibc,
- # but shouldn't because it is POSIX. This needs to be fixed
- # in uClibc. Also, we really should us append-cppflags but
- # monkey's build system doesn't respect CPPFLAGS. This needs
- # to be fixed in monkey.
- use elibc_uclibc && append-cflags -D_GNU_SOURCE
-
- # Non-autotools configure
- ./configure \
- --pthread-tls \
- --prefix=/usr \
- --sbindir=/usr/sbin \
- --webroot=${WEBROOT}/htdocs \
- --logdir=/var/log/${PN} \
- --mandir=/usr/share/man \
- --libdir=/usr/$(get_libdir) \
- --pidfile=/run/monkey.pid \
- --sysconfdir=/etc/${PN} \
- ${myconf} \
- || die
-}
-
-src_compile() {
- emake VERBOSE=1
-}
-
-src_install() {
- default
-
- newinitd "${FILESDIR}"/monkeyd.initd-r1 monkeyd
- newconfd "${FILESDIR}"/monkeyd.confd monkeyd
-
- # Move htdocs to docdir, bug #429632
- docompress -x /usr/share/doc/"${PF}"/htdocs.dist
- mv "${D}"${WEBROOT}/htdocs \
- "${D}"/usr/share/doc/"${PF}"/htdocs.dist || die
-
- keepdir \
- /var/log/monkeyd \
- ${WEBROOT}/htdocs
-
- # This needs to be created at runtime
- rm -rf "${D}"/run
-}