summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libnotify/libnotify-0.7.7.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/x11-libs/libnotify/libnotify-0.7.7.ebuild b/x11-libs/libnotify/libnotify-0.7.7.ebuild
index 0c6b8bd3842c..461066d5b7a6 100644
--- a/x11-libs/libnotify/libnotify-0.7.7.ebuild
+++ b/x11-libs/libnotify/libnotify-0.7.7.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit autotools eutils gnome.org multilib-minimal xdg-utils
+EAPI=6
+
+inherit gnome.org multilib-minimal xdg-utils
DESCRIPTION="A library for sending desktop notifications"
HOMEPAGE="https://git.gnome.org/browse/libnotify"
@@ -28,20 +29,16 @@ DEPEND="${RDEPEND}
PDEPEND="virtual/notification-daemon"
src_prepare() {
+ default
xdg_environment_reset
- sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
-
- if ! use test; then
- sed -i -e '/PKG_CHECK_MODULES(TESTS/d' configure.ac || die
- fi
-
- eautoreconf
}
multilib_src_configure() {
ECONF_SOURCE=${S} econf \
+ --disable-gtk-doc \
--disable-static \
- $(multilib_native_use_enable introspection)
+ $(multilib_native_use_enable introspection) \
+ $(use_enable test tests)
# work-around gtk-doc out-of-source brokedness
if multilib_is_native_abi; then