summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/dsx')
-rw-r--r--x11-misc/dsx/dsx-0.1-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/dsx/dsx-0.1-r1.ebuild b/x11-misc/dsx/dsx-0.1-r1.ebuild
new file mode 100644
index 000000000000..bb4c35bd7364
--- /dev/null
+++ b/x11-misc/dsx/dsx-0.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Command line selection of your X desktop environment"
+HOMEPAGE="https://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="
+ ${PYTHON_DEPS}
+ x11-apps/xinit"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ cp "${FILESDIR}/${P}" "${PN}" || die
+ default
+}
+
+src_install() {
+ python_doscript "${WORKDIR}/${PN}"
+}