summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/kdocker/kdocker-4.8-r2.ebuild')
-rw-r--r--x11-misc/kdocker/kdocker-4.8-r2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/kdocker/kdocker-4.8-r2.ebuild b/x11-misc/kdocker/kdocker-4.8-r2.ebuild
new file mode 100644
index 000000000000..812d28d88832
--- /dev/null
+++ b/x11-misc/kdocker/kdocker-4.8-r2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+LANGS="it"
+inherit bash-completion-r1 qt4-r2
+
+DESCRIPTION="Helper to dock any application into the system tray"
+HOMEPAGE="https://launchpad.net/kdocker/"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV:0:3}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsingleapplication[qt4(+),X]
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXpm
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS BUGS ChangeLog CREDITS README TODO )
+
+PATCHES=( "${FILESDIR}/${P}-unbundle-qtsingleapplication.patch" )
+
+src_prepare() {
+ qt4-r2_src_prepare
+
+ if ! use linguas_it ; then
+ sed -e '/^INSTALLS +=/s/translations//' -i kdocker.pro || die "sed failed"
+ fi
+
+ sed -i -e "/completion.path/s%/etc/bash_completion.d%$(get_bashcompdir)%" \
+ kdocker.pro || die "sed failed"
+}
+
+src_configure() {
+ eqmake4 PREFIX="${EPREFIX}/usr" SYSTEMQTSA=1
+}