summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/oroborus-desklaunch/oroborus-desklaunch-1.1.8.ebuild')
-rw-r--r--x11-misc/oroborus-desklaunch/oroborus-desklaunch-1.1.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/oroborus-desklaunch/oroborus-desklaunch-1.1.8.ebuild b/x11-misc/oroborus-desklaunch/oroborus-desklaunch-1.1.8.ebuild
new file mode 100644
index 000000000000..80128379d1c9
--- /dev/null
+++ b/x11-misc/oroborus-desklaunch/oroborus-desklaunch-1.1.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_PN=${PN/oroborus-//}
+
+DESCRIPTION="utility for creating desktop icons for Oroborus"
+HOMEPAGE="http://www.oroborus.org"
+SRC_URI="mirror://debian/pool/main/d/${MY_PN}/${MY_PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ !x11-wm/oroborus-extras"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+DOCS=( README debian/changelog debian/example_rc )
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.7-gentoo.diff
+}