summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/sddm/sddm-0.14.0-r4.ebuild')
-rw-r--r--x11-misc/sddm/sddm-0.14.0-r4.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/x11-misc/sddm/sddm-0.14.0-r4.ebuild b/x11-misc/sddm/sddm-0.14.0-r4.ebuild
index a79ea8f1a2f8..f67abdc0bdcf 100644
--- a/x11-misc/sddm/sddm-0.14.0-r4.ebuild
+++ b/x11-misc/sddm/sddm-0.14.0-r4.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit cmake-utils user
+inherit cmake-utils systemd user
DESCRIPTION="Simple Desktop Display Manager"
HOMEPAGE="https://github.com/sddm/sddm"
@@ -74,6 +74,8 @@ pkg_postinst() {
enewgroup ${PN}
enewuser ${PN} -1 -1 /var/lib/${PN} ${PN},video
+ systemd_reenable sddm.service
+
if use consolekit && use pam && [[ -e "${ROOT}"/etc/pam.d/system-login ]]; then
local line=$(grep "pam_ck_connector.*nox11" "${ROOT}"/etc/pam.d/system-login)
if [[ -z ${line} ]]; then