summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/bitlbee-steam/bitlbee-steam-1.0.1.ebuild')
-rw-r--r--x11-plugins/bitlbee-steam/bitlbee-steam-1.0.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/bitlbee-steam/bitlbee-steam-1.0.1.ebuild b/x11-plugins/bitlbee-steam/bitlbee-steam-1.0.1.ebuild
new file mode 100644
index 000000000000..9f82ca278a0c
--- /dev/null
+++ b/x11-plugins/bitlbee-steam/bitlbee-steam-1.0.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils autotools
+
+DESCRIPTION="Steam protocol plugin for BitlBee"
+HOMEPAGE="https://github.com/jgeboski/bitlbee-steam"
+SRC_URI="https://github.com/jgeboski/bitlbee-steam/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-libs/gmp:0
+ >=net-im/bitlbee-3.2.1[plugins]"
+DEPEND="${RDEPEND}
+ dev-libs/glib:2
+ virtual/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ --enable-minimal-flags
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}