summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/epplets/epplets-0.14.ebuild')
-rw-r--r--x11-plugins/epplets/epplets-0.14.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/epplets/epplets-0.14.ebuild b/x11-plugins/epplets/epplets-0.14.ebuild
new file mode 100644
index 000000000000..5f4d2c769fc7
--- /dev/null
+++ b/x11-plugins/epplets/epplets-0.14.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Base files for Enlightenment epplets and some epplets"
+HOMEPAGE="http://www.enlightenment.org/"
+SRC_URI="mirror://sourceforge/enlightenment/epplets-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="static-libs"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ media-libs/freeglut
+ media-libs/imlib2
+ >=x11-wm/enlightenment-0.16.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
+}