summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmacpimon')
-rw-r--r--x11-plugins/wmacpimon/files/Makefile.patch4
-rw-r--r--x11-plugins/wmacpimon/files/wmacpimon.c.patch4
-rw-r--r--x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild13
3 files changed, 10 insertions, 11 deletions
diff --git a/x11-plugins/wmacpimon/files/Makefile.patch b/x11-plugins/wmacpimon/files/Makefile.patch
index aab28fc89392..73646d10fa93 100644
--- a/x11-plugins/wmacpimon/files/Makefile.patch
+++ b/x11-plugins/wmacpimon/files/Makefile.patch
@@ -1,5 +1,5 @@
---- Makefile 2010-09-06 11:33:16.000000000 +0200
-+++ Makefile.new 2010-09-06 11:36:28.000000000 +0200
+--- a/Makefile 2010-09-06 11:33:16.000000000 +0200
++++ b/Makefile 2010-09-06 11:36:28.000000000 +0200
@@ -1,8 +1,5 @@
-OPT = -O3 -DACPI
-
diff --git a/x11-plugins/wmacpimon/files/wmacpimon.c.patch b/x11-plugins/wmacpimon/files/wmacpimon.c.patch
index 001c1d8c96be..adc03ce3fd0c 100644
--- a/x11-plugins/wmacpimon/files/wmacpimon.c.patch
+++ b/x11-plugins/wmacpimon/files/wmacpimon.c.patch
@@ -1,5 +1,5 @@
---- wmacpimon.c 2004-07-08 14:16:22.184359328 +0200
-+++ wmacpimon.c 2004-07-08 14:15:59.677780848 +0200
+--- a/wmacpimon.c 2004-07-08 14:16:22.184359328 +0200
++++ b/wmacpimon.c 2004-07-08 14:15:59.677780848 +0200
@@ -314,7 +314,7 @@
acpinfo = calloc(1, sizeof(ACPInfo));
dockapp->blink = OFF;
diff --git a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
index d902e3de4a33..ffc03d2648bb 100644
--- a/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
+++ b/x11-plugins/wmacpimon/wmacpimon-0.2.1.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=6
DESCRIPTION="DockApp monitors the temperature and Speedstep features in ACPI-based systems"
HOMEPAGE="http://www.vrlteam.org/wmacpimon/"
@@ -19,18 +18,18 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-base/xorg-proto"
-src_prepare() {
+PATCHES=(
# patch wmacpimon.c file to set default path for
# wmacpimon.prc to /var/tmp/
- epatch "${FILESDIR}"/wmacpimon.c.patch
+ "${FILESDIR}/wmacpimon.c.patch"
# fix LDFLAGS ordering. See bug #248618.
# fix LDFLAGS ordering again and other stuff. See bug #336091.
- epatch "${FILESDIR}"/Makefile.patch
-}
+ "${FILESDIR}/Makefile.patch"
+)
src_install() {
- dobin wmacpimond wmacpimon || die "dobin failed."
+ dobin wmacpimond wmacpimon
dodoc AUTHORS ChangeLog README
newinitd "${FILESDIR}"/wmacpimon.initscript wmacpimon
}