summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmhdplop/wmhdplop-0.9.11.ebuild')
-rw-r--r--x11-plugins/wmhdplop/wmhdplop-0.9.11.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/wmhdplop/wmhdplop-0.9.11.ebuild b/x11-plugins/wmhdplop/wmhdplop-0.9.11.ebuild
new file mode 100644
index 000000000000..2806056295d9
--- /dev/null
+++ b/x11-plugins/wmhdplop/wmhdplop-0.9.11.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="a dockapp for monitoring disk activities with fancy visuals"
+HOMEPAGE="https://www.dockapps.net/wmhdplop"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="media-libs/imlib2[X]
+ x11-libs/libX11
+ x11-libs/libXext
+ media-fonts/corefonts
+ >=media-libs/freetype-2"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.10-cflags.patch
+)
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_prepare() {
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf --disable-gkrellm
+}