summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild')
-rw-r--r--x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild b/x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..25aba7a574f8
--- /dev/null
+++ b/x11-plugins/wmlpq/wmlpq-0.2.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils flag-o-matic toolchain-funcs
+
+IUSE=""
+
+DESCRIPTION="Windowmaker dockapp which monitors up to 5 printqueues"
+SRC_URI="http://www.ur.uklinux.net/wmlpq/dl/wmlpq_0.2.1.tar.gz"
+HOMEPAGE="http://www.ur.uklinux.net/wmlpq/"
+
+DEPEND="x11-libs/libdockapp"
+
+RDEPEND=""
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~ppc ~x86"
+
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-makefile-ldflags.patch"
+}
+
+src_compile()
+{
+ append-ldflags "-L/usr/X11R6/lib -L/usr/local/lib"
+ emake CC=$(tc-getCC) LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install()
+{
+ dodir /usr/bin || die
+ emake DESTDIR="${D}/usr/bin" install || die "Installation failed"
+
+ dodoc README sample.wmlpqrc || die
+ newman wmlpq.1x wmlpq.1 || die
+
+ domenu "${FILESDIR}/${PN}.desktop" || die
+}