summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/wmtime/wmtime-1.4.ebuild')
-rw-r--r--x11-plugins/wmtime/wmtime-1.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmtime/wmtime-1.4.ebuild b/x11-plugins/wmtime/wmtime-1.4.ebuild
new file mode 100644
index 000000000000..b5a556032361
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmtime"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install () {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ dodoc BUGS CHANGES HINTS README TODO
+}