summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/pangoterm')
-rw-r--r--x11-terms/pangoterm/Manifest1
-rw-r--r--x11-terms/pangoterm/pangoterm-0.0_pre20150913.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/x11-terms/pangoterm/Manifest b/x11-terms/pangoterm/Manifest
index 31275dfa102f..fe07f842d3f2 100644
--- a/x11-terms/pangoterm/Manifest
+++ b/x11-terms/pangoterm/Manifest
@@ -1 +1,2 @@
DIST pangoterm-0.0_pre20150323.tar.gz 22053 SHA256 8df2bebdd70a77698803d3dd12472b313e29aa5e6387a7b926e0988e0689cf00 SHA512 c8614d51459c68bb03a95e1a59a31d5c199c94001995f880f23a369b9aa6ee72a6769790a8c4592d8829eb52ea246ef051fd36fd729f35c4a80931fd9e42b916 WHIRLPOOL 30adcf8098f3ef03c57f47e7f01ae996572058fc8318e4e31ac2d88ab2d8054c9d5e279bc5721a98bb66a5620356f7dde1aaf7d1a0eeca14c53069eef1126140
+DIST pangoterm-0.0_pre20150913.tar.gz 22074 SHA256 9fcdaaaa572f0e5fb3ac7b1fe3119e724373ed0250518efd47601f902acd1335 SHA512 2efed960bde9378ea25d96e41460245925952d50f60a4f0580ffc71519acb278101cd16c3aedaa8037c2734f09d14a0590731a1a42fe2f357ef9222a8e0bd260 WHIRLPOOL f07e8f407a62fa3e55f312b89937d5b5d6adfd2a4ccdee8e21b0c1d301bdc6b9684bec03f6cc6b2cc222b6e154408116fbd92596bd44a97f42564871a07215e2
diff --git a/x11-terms/pangoterm/pangoterm-0.0_pre20150913.ebuild b/x11-terms/pangoterm/pangoterm-0.0_pre20150913.ebuild
new file mode 100644
index 000000000000..d2ef7aabf5e5
--- /dev/null
+++ b/x11-terms/pangoterm/pangoterm-0.0_pre20150913.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A GTK/Pango-based terminal that uses libvterm to provide terminal emulation"
+HOMEPAGE="http://www.leonerd.org.uk/code/pangoterm/"
+SRC_URI="https://dev.gentoo.org/~tranquility/distfiles/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-libs/libvterm-neovim"
+RDEPEND="${DEPEND}
+ dev-libs/glib:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/pango
+"
+
+S=${WORKDIR}/pangoterm-0
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" install
+}