summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-terms/rxvt-unicode')
-rw-r--r--x11-terms/rxvt-unicode/metadata.xml2
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.21.ebuild12
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.22-r1.ebuild8
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.22-r2.ebuild8
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild8
5 files changed, 19 insertions, 19 deletions
diff --git a/x11-terms/rxvt-unicode/metadata.xml b/x11-terms/rxvt-unicode/metadata.xml
index fe671825fc57..a7dc1d11bbc0 100644
--- a/x11-terms/rxvt-unicode/metadata.xml
+++ b/x11-terms/rxvt-unicode/metadata.xml
@@ -16,7 +16,7 @@
<flag name="iso14755">Enable ISO-14755 support</flag>
<flag name="mousewheel">Enable scrolling via mouse wheel or buttons 4 and 5</flag>
<flag name="perl">Enable perl script support. You can still disable this at runtime with -pe ""</flag>
-<flag name="pixbuf">Enable transparency support using gtk's pixbuf</flag>
+<flag name="gdk-pixbuf">Enable transparency support using <pkg>x11-libs/gdk-pixbuf</pkg></flag>
<flag name="secondary-wheel">Support for wheel scrolling on secondary screens (like mutt). Read http://lists.schmorp.de/pipermail/rxvt-unicode/2011q4/001491.html</flag>
<flag name="unicode3">Use 21 instead of 16 bits to represent unicode characters</flag>
<flag name="utmp">Enable utmp support</flag>
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.21.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.21.ebuild
index 91c9ca6b1e95..88d63b06268e 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.21.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.21.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,8 +13,8 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
IUSE="
256-color alt-font-width blink buffer-on-clear +focused-urgency
- fading-colors +font-styles iso14755 +mousewheel +perl pixbuf secondary-wheel
- startup-notification xft unicode3 +vanilla wcwidth
+ fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel +perl
+ secondary-wheel startup-notification xft unicode3 +vanilla wcwidth
"
RDEPEND="
@@ -22,7 +22,7 @@ RDEPEND="
kernel_Darwin? ( dev-perl/Mac-Pasteboard )
media-libs/fontconfig
perl? ( dev-lang/perl:= )
- pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
startup-notification? ( x11-libs/startup-notification )
x11-libs/libX11
x11-libs/libXrender
@@ -86,12 +86,12 @@ src_configure() {
$(use_enable blink text-blink) \
$(use_enable fading-colors fading) \
$(use_enable font-styles) \
+ $(use_enable gdk-pixbuf pixbuf) \
$(use_enable mousewheel) \
$(use_enable perl) \
- $(use_enable pixbuf) \
$(use_enable startup-notification) \
- $(use_enable xft) \
$(use_enable unicode3) \
+ $(use_enable xft) \
${myconf}
}
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r1.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r1.ebuild
index fa608b95016e..cf6db15ce87f 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r1.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r1.ebuild
@@ -12,8 +12,8 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
IUSE="
- 256-color blink fading-colors +font-styles iso14755 +mousewheel +perl
- pixbuf startup-notification unicode3 xft
+ 256-color blink fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel
+ +perl startup-notification unicode3 xft
"
RESTRICT="test"
@@ -22,7 +22,7 @@ RDEPEND="
kernel_Darwin? ( dev-perl/Mac-Pasteboard )
media-libs/fontconfig
perl? ( dev-lang/perl:= )
- pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
startup-notification? ( x11-libs/startup-notification )
x11-libs/libX11
x11-libs/libXrender
@@ -55,10 +55,10 @@ src_configure() {
$(use_enable blink text-blink) \
$(use_enable fading-colors fading) \
$(use_enable font-styles) \
+ $(use_enable gdk-pixbuf pixbuf) \
$(use_enable iso14755) \
$(use_enable mousewheel) \
$(use_enable perl) \
- $(use_enable pixbuf) \
$(use_enable startup-notification) \
$(use_enable unicode3) \
$(use_enable xft)
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r2.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r2.ebuild
index ffbed292e804..c55c0cbd79ef 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r2.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.22-r2.ebuild
@@ -12,8 +12,8 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
IUSE="
- 256-color blink fading-colors +font-styles iso14755 +mousewheel +perl
- pixbuf startup-notification unicode3 +utmp +wtmp xft
+ 256-color blink fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel
+ +perl startup-notification unicode3 +utmp +wtmp xft
"
RESTRICT="test"
@@ -24,7 +24,7 @@ RDEPEND="
x11-libs/libXrender
kernel_Darwin? ( dev-perl/Mac-Pasteboard )
perl? ( dev-lang/perl:= )
- pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
startup-notification? ( x11-libs/startup-notification )
xft? ( x11-libs/libXft )
"
@@ -62,10 +62,10 @@ src_configure() {
$(use_enable blink text-blink) \
$(use_enable fading-colors fading) \
$(use_enable font-styles) \
+ $(use_enable gdk-pixbuf pixbuf) \
$(use_enable iso14755) \
$(use_enable mousewheel) \
$(use_enable perl) \
- $(use_enable pixbuf) \
$(use_enable startup-notification) \
$(use_enable unicode3) \
$(use_enable utmp) \
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
index 376b8036d825..480a785e27ee 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
@@ -14,8 +14,8 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
IUSE="
- 256-color blink fading-colors +font-styles iso14755 +mousewheel +perl
- pixbuf startup-notification unicode3 +utmp +wtmp xft
+ 256-color blink fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel
+ +perl startup-notification unicode3 +utmp +wtmp xft
"
RESTRICT="test"
@@ -26,7 +26,7 @@ RDEPEND="
x11-libs/libXrender
kernel_Darwin? ( dev-perl/Mac-Pasteboard )
perl? ( dev-lang/perl:= )
- pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
startup-notification? ( x11-libs/startup-notification )
xft? ( x11-libs/libXft )
"
@@ -66,10 +66,10 @@ src_configure() {
$(use_enable blink text-blink) \
$(use_enable fading-colors fading) \
$(use_enable font-styles) \
+ $(use_enable gdk-pixbuf pixbuf) \
$(use_enable iso14755) \
$(use_enable mousewheel) \
$(use_enable perl) \
- $(use_enable pixbuf) \
$(use_enable startup-notification) \
$(use_enable unicode3) \
$(use_enable utmp) \