summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r300.ebuild')
-rw-r--r--x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r300.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r300.ebuild b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r300.ebuild
new file mode 100644
index 000000000000..5094a6dc0a0f
--- /dev/null
+++ b/x11-themes/gtk-engines-xfce/gtk-engines-xfce-3.0.1-r300.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_PN=gtk-xfce-engine
+inherit xfconf
+
+DESCRIPTION="A port of Xfce engine to GTK+ 3.x"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${MY_PN}/${PV%.*}/${MY_PN}-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-3.2:3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+pkg_setup() {
+ XFCONF=(
+ --disable-gtk2
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}