summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/vanilla-dmz-aa-xcursors/vanilla-dmz-aa-xcursors-0.4.ebuild')
-rw-r--r--x11-themes/vanilla-dmz-aa-xcursors/vanilla-dmz-aa-xcursors-0.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/vanilla-dmz-aa-xcursors/vanilla-dmz-aa-xcursors-0.4.ebuild b/x11-themes/vanilla-dmz-aa-xcursors/vanilla-dmz-aa-xcursors-0.4.ebuild
new file mode 100644
index 000000000000..e8b4eff370e2
--- /dev/null
+++ b/x11-themes/vanilla-dmz-aa-xcursors/vanilla-dmz-aa-xcursors-0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_PN="Vanilla-DMZ-AA"
+DESCRIPTION="Style neutral scalable cursor theme"
+HOMEPAGE="http://jimmac.musichall.cz/themes.php?skin=7"
+SRC_URI="http://jimmac.musichall.cz/zip/${P/-xcursors}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 sparc x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_PN}
+
+src_install() {
+ insinto /usr/share/cursors/xorg-x11/${MY_PN}
+ doins -r cursors || die "doins failed"
+}
+
+pkg_postinst() {
+ elog "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ elog "and add the following line:"
+ elog "Xcursor.theme: ${MY_PN}"
+ elog
+ elog "You can change the size by adding a line like:"
+ elog "Xcursor.size: 48"
+ elog
+ elog "Also, to globally use this set of mouse cursors edit the file:"
+ elog " /usr/share/cursors/xorg-x11/default/index.theme"
+ elog "and change the line:"
+ elog " Inherits=[current setting]"
+ elog "to"
+ elog " Inherits=${MY_PN}"
+ elog
+ elog "Note this will be overruled by a user's ~/.Xdefaults file."
+ elog
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn "the Device section of your xorg.conf file:"
+ ewarn " Option \"HWCursor\" \"false\""
+}