summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/adwaita-qt/adwaita-qt-1.0-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-themes/adwaita-qt/adwaita-qt-1.0-r1.ebuild b/x11-themes/adwaita-qt/adwaita-qt-1.0-r1.ebuild
new file mode 100644
index 000000000000..e01fc3aea41e
--- /dev/null
+++ b/x11-themes/adwaita-qt/adwaita-qt-1.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="A style to bend Qt applications to look like they belong into GNOME Shell"
+HOMEPAGE="https://github.com/MartinBriza/adwaita-qt"
+SRC_URI="https://github.com/MartinBriza/${PN}/archive/${PV}/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+
+IUSE="gnome"
+
+RDEPEND="
+ gnome? ( x11-themes/QGnomePlatform )
+ dev-qt/qtwidgets:5
+ dev-qt/qtdbus:5
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ BUILD_DIR="${WORKDIR}/${PN}_qt5"
+ local mycmakeargs=( -DUSE_QT4=OFF )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake-utils_src_compile -C "${_d}"
+ done
+}
+
+src_install() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake-utils_src_install -C "${_d}"
+ done
+}