summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/Manifest1
-rw-r--r--x11-wm/icewm/icewm-2.2.1.ebuild153
2 files changed, 154 insertions, 0 deletions
diff --git a/x11-wm/icewm/Manifest b/x11-wm/icewm/Manifest
index e0be8cb119d0..854ac481f3d6 100644
--- a/x11-wm/icewm/Manifest
+++ b/x11-wm/icewm/Manifest
@@ -1,3 +1,4 @@
DIST icewm-2.0.1.tar.lz 1694439 BLAKE2B 1476f33fa7350a98b7eca8c5c265455d0a78b28bcbd35ab78969b528ae02d3c960fb73cf2b24ea999ee5e08c9f0641d3502c7d5ed8b285777162c334d645b6db SHA512 ac4126b38d592aed60d2269f58c5a1612b61e871565e3c3e51bc2b430e4da6a4708f78e86c16091fa4dfb9eefd4109ae89102ab708e3bce9a44f1e5fe1970c59
DIST icewm-2.1.2.tar.lz 1694969 BLAKE2B 640af2b7afb34ebcf6fc4f1762161bd8cae124e58735ad3e5af3f8a12723ead71e491fbef9e9119792c54e4e116c7cc491847da1e103b2c46765044bfda71f2d SHA512 92c52b057c7ac1c81eb72cb01d4041715fae2b1c221ecc0e5286a9bfad87e1607a3d7c60dde125436ad32c9a72dac01ee82a3bfe4b671b2d458ba3ce4c0c5a62
DIST icewm-2.2.0.tar.lz 1697312 BLAKE2B c030b7675a645b91ad3e2476735acc0c2cd4425227d96b99ffc81d57e859f8c6ece029b892f32bff2fbba0683f3e279fd73446e935d5c76a1c472376897810ba SHA512 c0d84bba176f30e7a5a1d8272e306279dfc2e7c130461d72b45fe55c691a6d262484dd4c7b818ac7ec55db878cad3c84bba33d6e451355036fa4e7ba89ee1fdb
+DIST icewm-2.2.1.tar.lz 1697220 BLAKE2B a1c236c5aa3f2b958f3ad53c6d757abbce344da3c1c9c8f49bd4c986c68aef7421e799100dfabcb03e612d4c6a44af6a063080730b054e96ee054c85c21d5d1e SHA512 700122ace9a120300a06f17f334b76c12395154693583587527254903f53d12feb6e991754fc714960cc78b0d7809202879e43f2508f4d7ffa3fc7af84e628d6
diff --git a/x11-wm/icewm/icewm-2.2.1.ebuild b/x11-wm/icewm/icewm-2.2.1.ebuild
new file mode 100644
index 000000000000..7b0d626e90a0
--- /dev/null
+++ b/x11-wm/icewm/icewm-2.2.1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools unpacker
+
+DESCRIPTION="Ice Window Manager with Themes"
+HOMEPAGE="https://ice-wm.org/ https://github.com/ice-wm/icewm"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/ice-wm/icewm/releases/download/${PV}/${P}.tar.lz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+alsa ao bidi debug +gdk-pixbuf imlib nls truetype uclibc xinerama"
+
+# Tests broken in all versions, patches welcome, bug #323907, #389533
+RESTRICT="test"
+
+REQUIRED_USE="|| ( alsa ao )"
+#?? ( gdk-pixbuf imlib )
+
+#fix for icewm preversion package names
+S="${WORKDIR}/${P/_}"
+
+# These are the core dependencies of icewm.
+# Look into configure.ac and search for PKG_CHECK_MODULES([CORE]
+CORE_DEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrender
+"
+
+RDEPEND="
+ ${CORE_DEPEND}
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXft
+ x11-libs/libXpm
+ x11-libs/libXrandr
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/libsndfile[alsa]
+ )
+ ao? (
+ media-libs/libao
+ media-libs/libsndfile
+ )
+ bidi? ( dev-libs/fribidi )
+ gdk-pixbuf? (
+ x11-libs/gdk-pixbuf-xlib
+ >=x11-libs/gdk-pixbuf-2.42.0:2
+ )
+ !gdk-pixbuf? (
+ imlib? (
+ gnome-base/librsvg:2
+ media-libs/imlib2
+ )
+ !imlib? (
+ media-libs/libpng:0=
+ virtual/jpeg
+ )
+ )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ $(unpacker_src_uri_depends)
+ x11-base/xorg-proto
+ gdk-pixbuf? ( gnome-base/librsvg:2 )
+"
+
+BDEPEND="
+ app-text/asciidoc
+ virtual/pkgconfig
+ nls? ( >=sys-devel/gettext-0.19.8 )
+"
+
+pkg_pretend() {
+ if use gdk-pixbuf && use imlib ; then
+ einfo 'Confilcting USE flags have been enabled:'
+ einfo '"gdk-pixbuf" and "imlib" exclude each other!'
+ einfo 'Using "gdk-pixbuf".'
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local icesound
+ if use alsa && use ao ; then
+ icesound="alsa,ao"
+ elif use alsa ; then
+ icesound="alsa"
+ elif use ao ; then
+ icesound="ao"
+ fi
+
+ local myconf=(
+ --enable-logevents
+ --enable-xrandr
+ --with-cfgdir="${EPREFIX}"/etc/icewm
+ --with-docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+ --with-icesound="${icesound}"
+ --with-libdir="${EPREFIX}"/usr/share/icewm
+ $(use_enable bidi fribidi)
+ $(use_enable debug)
+ $(use_enable debug logevents)
+ $(use_enable gdk-pixbuf)
+ $(use_enable imlib imlib2)
+ $(use_enable nls i18n)
+ $(use_enable nls)
+ $(use_enable xinerama)
+ )
+ if use truetype ; then
+ myconf+=(
+ --enable-shape
+ )
+ else
+ myconf+=(
+ --disable-xfreetype
+ --enable-corefonts
+ )
+ fi
+
+ econf "${myconf[@]}"
+
+ sed \
+ -e "s:/icewm-\$(VERSION)::" \
+ -e "s:ungif:gif:" \
+ -i src/Makefile || die
+}
+
+src_install() {
+ local DOCS=( AUTHORS ChangeLog NEWS README.md TODO VERSION )
+
+ default
+
+ docinto html
+ dodoc doc/icewm.html
+ dodoc man/*.html
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/icewm"
+}