summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/lumina')
-rw-r--r--x11-wm/lumina/Manifest1
-rw-r--r--x11-wm/lumina/lumina-0.8.8_p1.ebuild47
-rw-r--r--x11-wm/lumina/lumina-9999.ebuild46
-rw-r--r--x11-wm/lumina/metadata.xml28
4 files changed, 122 insertions, 0 deletions
diff --git a/x11-wm/lumina/Manifest b/x11-wm/lumina/Manifest
new file mode 100644
index 000000000000..94e32557654f
--- /dev/null
+++ b/x11-wm/lumina/Manifest
@@ -0,0 +1 @@
+DIST lumina-0.8.8_p1.tar.gz 53783856 SHA256 52bd8ec956e0a9f89c87bd957e308705aab3ac8c72130a606746af982bf361b7 SHA512 5fbfb6ad19a10b286001252cb2c93e92d4e2ed12a94c29f178afd777d0f2ff5f4d44b0300a40446f89d6c73237155d5963cda966c3fe16d4e9f07fcd4bddc6bb WHIRLPOOL 2e772fe413610ec7814c0e1de9c263c0d84afc45d9a308759ae442f8951fec7c82b16d5c8cb7eba5ce0e6f96f35a5410873370b1732e572ed469133089ad6906
diff --git a/x11-wm/lumina/lumina-0.8.8_p1.ebuild b/x11-wm/lumina/lumina-0.8.8_p1.ebuild
new file mode 100644
index 000000000000..fbc0e74602af
--- /dev/null
+++ b/x11-wm/lumina/lumina-0.8.8_p1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils vcs-snapshot
+
+COMMIT_ID="248abdd"
+DESCRIPTION="Lumina desktop environment"
+HOMEPAGE="http://lumina-desktop.org/"
+SRC_URI="https://github.com/pcbsd/lumina/archive/${COMMIT_ID}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libxcb:0
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm"
+
+RDEPEND="${DEPEND}
+ kde-frameworks/oxygen-icons
+ x11-misc/numlockx
+ x11-wm/fluxbox
+ x11-apps/xbacklight
+ media-sound/alsa-utils
+ sys-power/acpi
+ app-admin/sysstat"
+
+src_configure(){
+ eqmake5 PREFIX="${ROOT}usr" L_ETCDIR="${ROOT}etc" LIBPREFIX="${ROOT}usr/$(get_libdir)" DESTDIR="${D}" CONFIG+="NO_I18N"
+}
+
+src_install(){
+ default
+ mv "${D}"/etc/luminaDesktop.conf.dist "${D}"/etc/luminaDesktop.conf || die
+ mv "${D}"/?umina-* "${D}"/usr/bin || die
+}
diff --git a/x11-wm/lumina/lumina-9999.ebuild b/x11-wm/lumina/lumina-9999.ebuild
new file mode 100644
index 000000000000..606868b17714
--- /dev/null
+++ b/x11-wm/lumina/lumina-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit git-r3 qmake-utils
+
+DESCRIPTION="Lumina desktop environment"
+HOMEPAGE="http://lumina-desktop.org/"
+EGIT_REPO_URI="https://github.com/pcbsd/lumina"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="dev-qt/linguist-tools:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtcore:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libxcb:0
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-wm"
+
+RDEPEND="${DEPEND}
+ kde-frameworks/oxygen-icons
+ x11-misc/numlockx
+ x11-wm/fluxbox
+ x11-apps/xbacklight
+ media-sound/alsa-utils
+ sys-power/acpi
+ app-admin/sysstat"
+
+src_configure(){
+ eqmake5 PREFIX="${ROOT}usr" L_ETCDIR="${ROOT}etc" LIBPREFIX="${ROOT}usr/$(get_libdir)" DESTDIR="${D}" CONFIG+="NO_I18N"
+}
+
+src_install(){
+ default
+ mv "${D}"/etc/luminaDesktop.conf.dist "${D}"/etc/luminaDesktop.conf || die
+ mv "${D}"/?umina-* "${D}"/usr/bin || die
+}
diff --git a/x11-wm/lumina/metadata.xml b/x11-wm/lumina/metadata.xml
new file mode 100644
index 000000000000..cd37de95715d
--- /dev/null
+++ b/x11-wm/lumina/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>rubin@xs4all.nl</email>
+ <name>Rubin Simons</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>ken@pcbsd.org</email>
+ <name>Ken Moore</name>
+ </maintainer>
+ <remote-id type="github">pcbsd/lumina</remote-id>
+ <bugs-to>https://github.com/pcbsd/lumina/issues</bugs-to>
+ <doc lang="en">http://lumina-desktop.org/handbook/</doc>
+ </upstream>
+ <longdescription lang="en">The Lumina Desktop Environment is a lightweight system interface that is designed for use on any Unix-like operating system. It takes a plugin-based approach, allowing the entire interface to be assembled/arranged by each individual user as desired, with a system-wide default layout which was setup by the system administrator. This allows every system (or user session) to be designed to maximize the individual user's productivity.
+
+ The Lumina desktop developers understand that the point of a computer system is to run applications, so Lumina was designed to require as few system dependencies/requirements as possible. This allows it to be used to revitalize older systems or to allow the user to run applications that may need a higher percentage of the system resources than were previously available with other desktop environments.
+
+ Lumina is created/distributed under the 3-clause BSD license, allowing it to be used by anyone, anywhere (including in proprietary distributions). It has been written from scratch in C++/Qt5 and is not based on any existing desktop's code-base. It also does not use any of the Linux-based desktop frameworks (ConsoleKit, PolicyKit, D-Bus, systemd, etc), instead using a simple built-in interface layer for communicating directly with the operating system.
+</longdescription>
+</pkgmetadata>