summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/xpra/files/xpra-0.17.4-deprecated-avcodec.patch11
-rw-r--r--x11-wm/xpra/xpra-0.17.4.ebuild3
2 files changed, 13 insertions, 1 deletions
diff --git a/x11-wm/xpra/files/xpra-0.17.4-deprecated-avcodec.patch b/x11-wm/xpra/files/xpra-0.17.4-deprecated-avcodec.patch
new file mode 100644
index 00000000000..13bd4be892d
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-0.17.4-deprecated-avcodec.patch
@@ -0,0 +1,11 @@
+--- xpra-0.17.4/setup.py
++++ xpra-0.17.4/setup.py
+@@ -660,7 +660,7 @@
+ "-Wno-unused-function",
+ "-Wno-sometimes-uninitialized"]
+ elif get_gcc_version()>=[4, 4]:
+- eifd = ["-Werror",
++ eifd = ["-Werror", "-Wno-error=deprecated-declarations",
+ #CentOS 6.x gives us some invalid warnings in nvenc, ignore those:
+ #"-Wno-error=uninitialized",
+ #needed on Debian and Ubuntu to avoid this error:
diff --git a/x11-wm/xpra/xpra-0.17.4.ebuild b/x11-wm/xpra/xpra-0.17.4.ebuild
index 4b4e7090f39..9484fcce002 100644
--- a/x11-wm/xpra/xpra-0.17.4.ebuild
+++ b/x11-wm/xpra/xpra-0.17.4.ebuild
@@ -88,7 +88,8 @@ python_prepare_all() {
epatch \
"${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.16.2-prefix.patch
+ "${FILESDIR}"/${PN}-0.16.2-prefix.patch \
+ "${FILESDIR}"/${PN}-0.17.4-deprecated-avcodec.patch
if use libav ; then
if ! has_version ">=media-video/libav-9" ; then