summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/thunar-archive-plugin')
-rw-r--r--xfce-extra/thunar-archive-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.4.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/xfce-extra/thunar-archive-plugin/Manifest b/xfce-extra/thunar-archive-plugin/Manifest
index 329fd8af3672..6a7205f7e96a 100644
--- a/xfce-extra/thunar-archive-plugin/Manifest
+++ b/xfce-extra/thunar-archive-plugin/Manifest
@@ -1 +1,2 @@
DIST thunar-archive-plugin-0.3.1.tar.bz2 329005 BLAKE2B f1cc88acb86565c001734ae2ead50f79cd4e922922292446b3775a7ef5cce250787b202ef6633d453b40bf37f1841d6e1b9ee34350e784587612ea0d4030e6d4 SHA512 51157c2680b3fcc6b541d35fc2943a350a0354d7d5bbb5fbe8a9dcbbeaf4bf4f5fe62521b8e9a73254f70bbefc440357deade8181313da96270c280eb0464e68
+DIST thunar-archive-plugin-0.4.0.tar.bz2 350011 BLAKE2B aebe828396e75701b788dd22266ed154b3a8296b8f6a912fbd99d4ebda1db2ed2a5cbf957a381523194270b5f1ea8ae6af24ca61e35b3953de54b0477bffd6cf SHA512 6590d8765ac6eab14fae7758e4c47c66b52e79e2e4b01a86d25bd35492590925ca35e4bbade8a9d8f0c73386eaeda6863e2a7a39a2df2904404f7e2bfdd91a44
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.4.0.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.4.0.ebuild
new file mode 100644
index 000000000000..4e609144392c
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="https://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/thunar-1.7:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/0.3.1-fix-kde-ark.patch
+)
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}