summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.5.ebuild')
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.5.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.5.ebuild
new file mode 100644
index 000000000000..d52b90f154df
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="debug upower"
+
+RDEPEND=">=dev-libs/glib-2.20:=
+ dev-libs/libxml2:=
+ >=net-libs/libsoup-2.32:=
+ >=x11-libs/gtk+-2.14:2=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfce4-panel-4.10:=
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ XFCONF=(
+ $(use_enable upower)
+ $(xfconf_use_debug)
+ GEONAMES_USERNAME=Gentoo
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}