summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'xfce-extra/xfdashboard/xfdashboard-0.7.5.ebuild')
-rw-r--r--xfce-extra/xfdashboard/xfdashboard-0.7.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfdashboard/xfdashboard-0.7.5.ebuild b/xfce-extra/xfdashboard/xfdashboard-0.7.5.ebuild
new file mode 100644
index 000000000000..8639f9ddf744
--- /dev/null
+++ b/xfce-extra/xfdashboard/xfdashboard-0.7.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Maybe a GNOME shell like dashboard for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfdashboard/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.2:3
+ >=media-libs/clutter-1.12:1.0=[gtk]
+ >=x11-libs/libwnck-3:3=
+ x11-libs/libX11:=
+ x11-libs/libXcomposite:=
+ x11-libs/libXdamage:=
+ x11-libs/libXinerama:=
+ >=xfce-base/garcon-0.2.0:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfconf-4.13:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}