summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* sys-libs/timezone-data: mark 2016c stable for allMike Frysinger2016-05-081-1/+1
|
* sys-devel/gcc: add USE=vtv support for vtable verification #547040Mike Frysinger2016-05-087-2/+30
|
* app-misc/lcd4linux: update HOMEPAGEMike Frysinger2016-05-081-1/+1
|
* media-libs/libsfml: clean oldMichael Sterrett2016-05-087-330/+0
| | | | Package-Manager: portage-2.2.26
* games-emulation/dolphin: clean old (last user of libsfml-1)Michael Sterrett2016-05-083-311/+0
| | | | Package-Manager: portage-2.2.26
* profiles: media-libs/csfml and dev-python/pysfml are goneMichael Sterrett2016-05-081-7/+0
|
* dev-python/pysfml: dev-python/pysfml is goneMichael Sterrett2016-05-083-53/+0
|
* media-libs/csfml: media-libs/csfml is goneMichael Sterrett2016-05-084-119/+0
|
* dev-vcs/git: shorten DESCRIPTIONMike Gilbert2016-05-0812-12/+12
| | | | Package-Manager: portage-2.2.28_p97
* dev-vcs/git: reapply systemd unit changes in ~arch onlyMike Gilbert2016-05-086-4/+698
| | | | Package-Manager: portage-2.2.28_p97
* Revert "dev-vcs/git: for systemd, don't source /etc/conf.d/git-daemon"Mike Gilbert2016-05-081-1/+2
| | | | This reverts commit 843954e66426a8e87c42a2c3d3d99ca6fa7d4744.
* sys-kernel/git-sources: Linux patch 4.6_rc7Mike Pagano2016-05-082-0/+41
| | | | Package-Manager: portage-2.2.28
* l10n.eclass: Bump copyright yearJames Le Cuirot2016-05-081-1/+1
|
* l10n.eclass: Sort and normalize PLOCALES in l10n_find_plocales_changeJames Le Cuirot2016-05-081-1/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | l10n_find_plocales_change assumes that PLOCALES is sorted alphanumerically with a single space between each entry and no surrounding whitespace. This is not a bad assumption but it isn't documented and it's inconvenient in at least one particular case. MakeMKV uses non-standard locale names and I intend to map these using an associative array, which is possible as of EAPI 6. This allows me to do the following, though only with the above change as associative arrays are not ordered. declare -A MY_LOCALES MY_LOCALES=( [zh]=chi [da]=dan … ) PLOCALES="${!MY_LOCALES[@]}" inherit l10n src_prepare() { PLOCALES="${MY_LOCALES[@]}" l10n_find_plocales_changes … } src_install() { for locale in $(l10n_get_locales); do doins makemkv_${MY_LOCALES[${locale}]}.mo.gz done } Fixes bug #513242.
* games-roguelike/angband: version bump (bug #582468)Michael Sterrett2016-05-082-0/+118
| | | | Package-Manager: portage-2.2.26
* dev-lang/rakudo: re-add 9999, based on 2016.04-r1Marshall Brewer (Gentoo Key)2016-05-081-0/+83
| | | | Package-Manager: portage-2.2.28
* dev-lang/rakudo: revbump 2016.04-r1Marshall Brewer (Gentoo Key)2016-05-083-8/+116
| | | | | | | | | | | | | | - update ebuild to reflect the build-system - enable choice between gcc (default) and clang (use clang) - enable use of either MoarVM or JavaVM or both as backend (use java +moar) - inherit java-pkg-2.eclass - enable testing (use test) - abort when rakudo is already installed and JVM backend is wanted (known bug) - update to EAPI6 - add tomboy64 as secondary maintainer Package-Manager: portage-2.2.28
* dev-lang/nqp: re-add 9999, based on 2016.04-r1Marshall Brewer (Gentoo Key)2016-05-081-0/+91
|
* dev-lang/nqp: revbump nqp-2016.04-r1Marshall Brewer (Gentoo Key)2016-05-083-0/+313
| | | | | | | | | | | | | - update ebuild to reflect the build-system - inherit java-pkg-2.eclass - enable choice between gcc (default) and clang (use clang) - make MoarVM default backend (use +moar java) - enable optional use of system-provided jars (use +system-libs) - enable testing (use test) - update to EAPI6 - add tomboy64 as secondary maintainer Package-Manager: portage-2.2.28
* dev-lang/moarvm: mask use-flag asanMarshall Brewer (Gentoo Key)2016-05-081-0/+5
|
* dev-lang/moarvm: re-add 9999, based on 2016.04-r1Marshall Brewer (Gentoo Key)2016-05-081-16/+48
|
* dev-lang/moarvm: revbump 2016.04-r1Marshall Brewer (Gentoo Key)2016-05-083-0/+225
| | | | | | | | | | | | | | | | - update ebuild to reflect the build-system - enable choice between gcc (default) and clang (use clang) - enable optional compilation against system-libs (use +system-libs) (required patch submitted upstream) - enable optional use of sanitizers (use asan ubsan) - enable optional static build (use static-libs) - make jit optional (was mandatory) (use +jit) - make stronger optimization optional (was mandatory) (use optimize) - disable testing (will be performed with nqp) - update to EAPI6 - add tomboy64 as secondary maintainer Package-Manager: portage-2.2.28
* sys-process/memwatch: Version bump.Patrice Clement2016-05-082-0/+33
| | | | | | Gentoo-Bug: https://bugs.gentoo.org/582412 Package-Manager: portage-2.2.26
* app-crypt/efitools: version bump (1.7.0) for bug #533572Pawel Hajdan, Jr2016-05-081-0/+27
| | | | | | | | Credits: Ben Sagal - bug reporter Gabriel Marcano - uploaded git-based ebuild Package-Manager: portage-2.2.26
* www-client/chromium: beta channel bump (51.0.2704.36)Mike Gilbert2016-05-082-1/+1
| | | | Package-Manager: portage-2.2.28_p97
* www-client/chromium: dev channel bump (52.0.2723.2)Pawel Hajdan, Jr2016-05-083-0/+749
| | | | Package-Manager: portage-2.2.26
* dev-vcs/git: for systemd, don't source /etc/conf.d/git-daemonMike Gilbert2016-05-081-2/+1
| | | | Package-Manager: portage-2.2.28_p97
* app-text/qpdfview: version bump; EAPI=6; drop USE=qt4 to respect Qt team policyDavide Pesavento2016-05-082-0/+98
| | | | | | Gentoo-Bug: 565788 Package-Manager: portage-2.2.28
* sys-kernel/hardened-sources: remove 4.5.2-r1Anthony G. Basile2016-05-082-47/+0
| | | | | | This had broken user.pax.flags xattr namespace on tmpfs. Package-Manager: portage-2.2.26
* sys-kernel/hardened-sources: version bump to 4.5.3Anthony G. Basile2016-05-082-0/+47
| | | | | | vanilla-4.5.3 + genpatches-4.5-5 + grsecurity-3.1-4.5.3-201605080858 Package-Manager: portage-2.2.26
* x11-wm/enlightenment: Remove unneeded useflag descriptions from metadata.xmlPatrick Lauer2016-05-081-6/+0
| | | | Package-Manager: portage-2.2.28
* app-misc/mc: require glib-2.26.0:2 or higherYury V. Zaytsev2016-05-082-2/+2
| | | | | Signed-off-by: Yury V. Zaytsev <yury@shurup.com> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* app-misc/mc: remove dep on cvs from mc-4.8.17.ebuild & mc-9999.ebuildYury V. Zaytsev2016-05-082-4/+0
| | | | | | | | Dependency on cvs should be no longer necessary, as we have upgraded to a new enough version of gettext (0.18.1). Signed-off-by: Yury V. Zaytsev <yury@shurup.com> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
* dev-libs/re2: bump to 2016-05-01Mike Gilbert2016-05-083-0/+95
| | | | | Closes: https://github.com/gentoo/gentoo/pull/1213 Package-Manager: portage-2.2.28_p97
* dev-util/abi-compliance-checker: bump to 1.99.19Mike Gilbert2016-05-083-0/+30
| | | | Package-Manager: portage-2.2.28_p97
* dev-util/abi-dumper: New packageMike Gilbert2016-05-083-0/+37
| | | | Package-Manager: portage-2.2.28_p97
* dev-util/vtable-dumper: New packageMike Gilbert2016-05-083-0/+30
| | | | Package-Manager: portage-2.2.28_p97
* net-analyzer/nmapsi: version bumpDavide Pesavento2016-05-084-3/+54
| | | | Package-Manager: portage-2.2.28
* app-editors/tea: version bumpDavide Pesavento2016-05-082-0/+58
| | | | Package-Manager: portage-2.2.28
* media-video/qx11grab: sort RDEPENDDavide Pesavento2016-05-081-2/+3
| | | | Package-Manager: portage-2.2.28
* media-video/makemkv: Install everything to /usr, not some to /optJames Le Cuirot2016-05-081-5/+4
| | | | | | | | | | | | makemkvcon looks for files in ../share/MakeMKV. Installing them to /opt/share/MakeMKV is a bit weird and using /opt requires patching so it's not exactly supported by upstream. This means installing prebuilt binaries to /usr but we were previously having to install a freshly-built binary to /opt so we're screwing FHS either way. ;) Package-Manager: portage-2.2.28
* media-video/makemkv: Launch executables from the PATHJames Le Cuirot2016-05-082-15/+62
| | | | | | | | | | | Upstream launches wget as /usr/bin/wget and uses a hardcoded set of paths to search for other executables. All the required executables should be in the PATH anyway and this will fix prefixed systems. Also add missing dependency on wget. It's in @system but it's one of the less obvious entries. Package-Manager: portage-2.2.28
* media-video/makemkv: Patch implicit inclusion of sysmacros.h, #580342James Le Cuirot2016-05-082-1/+11
| | | | Package-Manager: portage-2.2.28
* media-video/makemkv: Use the l10n eclass to select localesJames Le Cuirot2016-05-081-11/+41
| | | | | | | | | Upstream uses non-standard locale names so map them with an associative array and perform some tricks. Thanks to Jan Chren for the initial work on this. Package-Manager: portage-2.2.28
* media-video/makemkv: Bump to 1.9.10, EAPI 6, minor fixesJan Chren2016-05-082-10/+17
|
* dev-lang/R: bump to 3.3.0, fix bug #567488Denis Dupeyron2016-05-082-2/+204
|
* net-p2p/litecoin-qt: fix .protocol file, bug #557430Anthony G. Basile2016-05-082-0/+13
| | | | Package-Manager: portage-2.2.26
* profiles: drop mask for removed net-libs/libqinfinityMichael Palimaka2016-05-091-5/+0
|
* net-libs/libqinfinity: remove last-rited packageMichael Palimaka2016-05-093-38/+0
|
* profiles: drop mask for removed kde-misc/kte-collaborativeMichael Palimaka2016-05-091-4/+0
|