summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-tex/latexdiff: version bump 1.1.1Alexey Korepanov2016-04-162-0/+33
|
* app-text/libabw: Add eautoreconf, EAPI=6Andreas Sturmlechner2016-04-161-3/+8
| | | | | | Gentoo-bug: 579028 Package-Manager: portage-2.2.27
* app-office/libreoffice: Drop old 5.1.1.3Andreas Sturmlechner2016-04-166-910/+0
| | | | Package-Manager: portage-2.2.27
* app-office/libreoffice: Bump libxmlsec tarball to 1.2.20Andreas Sturmlechner2016-04-162-2/+2
| | | | | | Gentoo-bug: 577278 Package-Manager: portage-2.2.27
* sys-process/procenv: version bump to 0.45Tim Harder2016-04-162-0/+20
|
* app-vim/vim-rest-console: version bump to 2.4.0Tim Harder2016-04-162-0/+22
|
* virtual/perl-if: Copy keywords from dev-lang/perlAndreas K. Hüttel2016-04-161-1/+1
| | | | Package-Manager: portage-2.2.28
* dev-perl/Plack: Remove oldAndreas K. Hüttel2016-04-163-91/+0
| | | | Package-Manager: portage-2.2.28
* dev-perl/PerlIO-via-Timeout: Remove oldAndreas K. Hüttel2016-04-162-34/+0
| | | | Package-Manager: portage-2.2.28
* dev-perl/Test-Warnings: Bump to version 0.26.0Kent Fredric2016-04-163-0/+49
| | | | | | | | | | | | | | | | | - EAPI6 - Add metadata and suggested test-deps Upstream: - Handle other handlers better - test improvements - Propagate to __WARN__ handlers Keywords: Dropped due to being unsatisfied on deps. ~alpha ~amd64-fbsd ~arm64 ~ia64 ~m68k ~s390 ~sh ~sparc Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/File-pushd: Bump to version 1.9.0Kent Fredric2016-04-162-0/+33
| | | | | | | | | | | | - EAPI6 Upstream: - Object destruction stops clobbering $@ - Tests fixed Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/Test-TCP: Bump to version 2.160.0Kent Fredric2016-04-162-0/+33
| | | | | Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/Test-SharedFork: Bump to version 0.350.0Kent Fredric2016-04-162-0/+29
| | | | | | | | | | - EAPI6 Upstream: - Add support for upcomming Test2 Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/Test-Script: Bump to version 1.100.0Kent Fredric2016-04-162-0/+25
| | | | | | | | | | | | | | - EAPI6 - Refine Deps Upstream: - IPC::Run3 workarounds - kill()'d scripts now considered failures - can now pass input via stdin - Now able to capture stderr/out with script_runs Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/Test-Requires: Bump to version 0.100.0Kent Fredric2016-04-162-0/+22
| | | | | | | | | | | - EAPI6 - Dep cleanup Upstream: - Minor packaging changes Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/Test-Pod-Coverage: Bump to version 1.100.0Kent Fredric2016-04-162-0/+27
| | | | | | | | | | | | | | - EAPI6 - Unwanted test/dep cleanup - Update LICENSE to "Artistic-2" Upstream: - Update license - Fix tests - doc patches Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/Test-Perl-Critic: Bump to 1.30.0Kent Fredric2016-04-162-0/+26
| | | | | | | | | | | | | | | - EAPI6 - Cleanup deps Upstream: - all_critic_ok() now parallelized over multiple cores Keywording: - Dropped 1 keyword due to new dependency: ppc Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/MCE: Added at version 1.705.0Kent Fredric2016-04-163-0/+63
| | | | | | | Required for new dev-perl/Test-Perl-Critic Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/Test-MockModule: Bump to version 0.110.0Kent Fredric2016-04-162-0/+30
| | | | | | | | | | | | | | | | | - EAPI6 - Cleanup tests Upstream: - unmock() on inherited subroutines will dispatch to the parent module, rather than replace the local subroutine with the parent's subroutine from the time of mocking (RT77439) Keywording: - New dependency causes the loss of: arm, hppa, ppc Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/SUPER: Add to tree at version 1.201.411.170Kent Fredric2016-04-163-0/+38
| | | | | | | Required for new dev-perl/Test-MockModule Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* dev-perl/Test-Mock-LWP-Dispatch: Bump to version 0.80.0Kent Fredric2016-04-163-0/+40
| | | | | | | | | | | | | - EAPI6 - Cleanup tests - Fix missing deps - Cleanup metadata Upstream: - Add map_passthrough method Package-Manager: portage-2.2.28 RepoMan-Options: --include-arches="alpha amd64 amd64-fbsd arm arm64 hppa ia64 m68k mips nios2 ppc ppc64 riscv s390 sh sparc sparc-fbsd x86 x86-fbsd"
* Revert "ssl-cert.eclass: add libressl support"Anthony G. Basile2016-04-161-8/+4
| | | | This reverts commit ad0c2ab2bdbd34f4550e49c56cfd5974d6a2c07a.
* ssl-cert.eclass: add libressl supportAnthony G. Basile2016-04-161-4/+8
|
* ssl-cert.eclass: add slot operators for dev-libs/opensslAnthony G. Basile2016-04-161-2/+2
|
* sys-kernel/genkernel-next: WhitespacePatrick Lauer2016-04-161-1/+0
| | | | Package-Manager: portage-2.2.28
* sys-kernel/hardened-sources: version bump to 4.4.7Anthony G. Basile2016-04-162-0/+47
| | | | | | vanilla-4.4.7 + genpatches-4.4-9 + grsecurity-3.1-4.4.7-201604152208 Package-Manager: portage-2.2.26
* app-text/poppler: Stable for HPPA PPC64 (bug #579752).Jeroen Roovers2016-04-161-1/+1
| | | | | Package-Manager: portage-2.2.28 RepoMan-Options: --ignore-arches
* dev-qt/qtcore: delete unused patchDavide Pesavento2016-04-161-12/+0
| | | | Package-Manager: portage-2.2.28
* dev-qt/qtcore: use subslot operator for libresslDavide Pesavento2016-04-161-1/+1
| | | | Package-Manager: portage-2.2.28
* dev-qt/qtcore: extend moc patch with workarounds for newer boost versionsDavide Pesavento2016-04-163-4/+20
| | | | | | Gentoo-Bug: 556104 Package-Manager: portage-2.2.28
* app-doc/cppman: RDEPEND fixesJan Chren2016-04-171-1/+1
| | | | | | Closes: https://github.com/gentoo/gentoo/pull/1276 Signed-off-by: Ian Delaney <idella4@gentoo.org>
* app-doc/cppman: require sqlite and threads for pythonJan Chren2016-04-171-0/+1
| | | | | | | Fixes https://github.com/aitjcize/cppman/issues/58. Closes: https://github.com/gentoo/gentoo/pull/1276 Signed-off-by: Ian Delaney <idella4@gentoo.org>
* dev-python/shortuuid: add Python 3.5 supportLouis Sautier2016-04-172-2/+4
| | | | | | | | add sub tags "remote-id" & "bugs-to" under tag <upstream> in metadata.xml Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1278 Signed-off-by: Ian Delaney <idella4@gentoo.org>
* net-misc/openntpd: Bump to 5.9_p1Paul B. Henson2016-04-163-0/+94
|
* dev-python/sphinxcontrib-issuetracker: remove kde projectMichael Palimaka2016-04-171-4/+0
| | | | Package-Manager: portage-2.2.28
* kde-misc/synaptiks: drop usage of dev-python/sphinxcontrib-issuetrackerMichael Palimaka2016-04-171-5/+8
| | | | | | Gentoo-bug: 527188 Package-Manager: portage-2.2.28
* sys-libs/glibc: restore 2.23-r1 with a maskMike Gilbert2016-04-162-0/+209
|
* kde-frameworks/extra-cmake-modules: Add missing RDEPENDJohannes Huber2016-04-161-0/+4
| | | | | | | | | | When kde_package_app_templates is used by a reverse dependency cmake -E tar "cvfj" is called in KDEPackageAppTemplates.cmake which apparently uses libarchive. Gentoo-bug: 577550 Package-Manager: portage-2.2.28
* Version bump, thsnks to Ettore Di GiacintoMikle Kolyada2016-04-162-0/+62
| | | | Package-Manager: portage-2.2.26
* dev-util/sysdig: Bump to 0.9.0Michał Górny2016-04-162-3/+86
|
* dev-util/sysdig: Remove ancient versions 0.1*Michał Górny2016-04-163-260/+0
|
* sys-libs/glibc: [QA] Disable custom patch to sysmacros.h #575232Patrick Lauer2016-04-161-0/+1
| | | | | | | Since this is not an upstream patch and it causes lots of breakage Acked by mgorny and zlogene in IRC Package-Manager: portage-2.2.28
* media-radio/flrig: Version bumpThomas Beierlein2016-04-162-0/+33
| | | | Package-Manager: portage-2.2.28
* media-radio/fldigi: Version bumpThomas Beierlein2016-04-162-0/+41
| | | | Package-Manager: portage-2.2.28
* dev-ruby/webmock: Version bump to 1.24.3Manuel Rüger2016-04-162-0/+53
| | | | Package-Manager: portage-2.2.28
* profiles: Mask plasma-meta:5 and khelpcenter:5 in kde profileAndreas Sturmlechner2016-04-161-0/+2
| | | | Signed-off-by: Johannes Huber <johu@gentoo.org>
* kde-frameworks/krunner: Pin kapptemplate blocker to slot 5Andreas Sturmlechner2016-04-161-1/+1
| | | | | | | | Gentoo-bug: 579534 Package-Manager: portage-2.2.27 Signed-off-by: Johannes Huber <johu@gentoo.org>
* kde-apps/kde-l10n: Fix LINGUAS=""Andreas Sturmlechner2016-04-161-4/+4
| | | | | | | | Gentoo-bug: 580170 Package-Manager: portage-2.2.27 Signed-off-by: Johannes Huber <johu@gentoo.org>
* net-p2p/ktorrent: Pin slot on net-libs/libktorrentJohannes Huber2016-04-161-2/+2
| | | | Package-Manager: portage-2.2.28
* net-p2p/ktorrent: Version bump 5.0Johannes Huber2016-04-162-0/+124
| | | | Package-Manager: portage-2.2.28