summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* app-emulation/xen-tools: use #!/sbin/openrc-run instead of #!/sbin/runscriptAustin English2016-05-185-5/+5
|
* app-emulation/xen-tools: rm old vns. 4.5.2Ian Delaney2016-05-153-954/+0
| | | | Package-Manager: portage-2.2.28
* app-emulation/xen-tools: rebumps: xen-tools-4.6.0-r11 xen-tools-4.6.0-r10Ian Delaney2016-05-153-0/+920
| | | | | | | | consequent to the security bug re patches of xsa-179 affecting qemuu Gentoo-bug: #582574 Package-Manager: portage-2.2.28
* app-emulation/xen-tools: revbumps subsequent to addition of xsa sec patchesIan Delaney2016-04-234-0/+1420
| | | | | | | | | versions; 4.5.2-r6 4.6.0-r10 4.6.1-r1 sec patches; xsa 172 173 Gentoo-bug: #579074 #579072 Package-Manager: portage-2.2.28
* app-emulation/xen-tools: correct typo in source of vn. 4.6.1Ian Delaney2016-04-141-0/+3
| | | | | | | | | noted in gentoo bug, set with an equivalent sed statement substituting an upstream patch, the sed being completed in one line Gentoo-bug: #575868 Package-Manager: portage-2.2.28
* app-emulation/xen-tools: clean old vulnerable vns.Ian Delaney2016-03-154-1415/+0
| | | | | | | | wrt the gentoo security bug Gentoo bug: #574012 Package-Manager: portage-2.2.26
* app-emulation/xen-tools: x86 stable wrt bug #574012Agostino Sarubbo2016-03-152-2/+2
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-emulation/xen-tools: amd64 stable wrt bug #574012Agostino Sarubbo2016-03-152-2/+2
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-emulation/xen-tools: revbumps; 4.5.2-r5, 4.6.0-r9Ian Delaney2016-02-203-0/+946
| | | | | | | | add sec patches xsa170 wrt the security bug Gentoo bug: #574012 Package-Manager: portage-2.2.26
* app-emulation/xen-tools: disable stackcheck in seabiosYixun Lan2016-02-193-2/+5
| | | | | | | | problem was seen in hardened system && using USE="-system-seabios" Gentoo-bug: 569810 Package-Manager: portage-2.2.27
* app-emulation/xen-tools: correct patching ovmf logicYixun Lan2016-02-192-16/+20
| | | | | | | while bumping ovmf, I found current logic not handling USE=ovmf enabled && ${OVMF_VER} is unset case Package-Manager: portage-2.2.27
* app-emulation/xen-tools: Move ovmf move into conditional sectionAustin S. Hemmelgarn2016-02-181-1/+1
| | | | Package-Manager: portage-2.2.27
* app-emulation/xen-tools: drop old versionsYixun Lan2016-02-186-2345/+0
| | | | Package-Manager: portage-2.2.27
* app-emulation/xen-tools: bump to 4.6.1, update ovmf-20151110Yixun Lan2016-02-183-0/+480
| | | | Package-Manager: portage-2.2.27
* app-emulation/xen-tools: enable USE=qemu-traditional by defaultDoug Goldstein2016-02-161-1/+1
| | | | | | | | To avoid breaking people, enable USE=qemu-traditional by default so that xen-tools behaves like it has in the past. Package-Manager: portage-2.2.26 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
* app-emulation/xen-tools: allow qemu-traditional to be disabledDoug Goldstein2016-02-152-0/+470
| | | | | | | | | Provide the ability for the qemu-traditional device model to be disabled. This device model should not be used unless you have machines that are depending on it (e.g. Windows domains). Package-Manager: portage-2.2.26 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
* Set appropriate maintainer types in metadata.xml (GLEP 67)Michał Górny2016-01-241-1/+1
|
* Replace all herds with appropriate projects (GLEP 67)Michał Górny2016-01-241-1/+4
| | | | | Replace all uses of herd with appropriate project maintainers, or no maintainers in case of herds requested to be disbanded.
* Unify quoting in metadata.xml files for machine processingMichał Górny2016-01-241-11/+11
| | | | | | | Force unified quoting in all metadata.xml files since lxml does not preserve original use of single and double quotes. Ensuring unified quoting before the process allows distinguishing the GLEP 67-related metadata.xml changes from unrelated quoting changes.
* app-emulation/xen-tools: x86 stable wrt bug #571552Agostino Sarubbo2016-01-222-2/+2
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-emulation/xen-tools: amd64 stable wrt bug #571552Agostino Sarubbo2016-01-222-2/+2
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-emulation/xen-tools: revbumps to vns. 4.5.2-r4 4.6.0-r7Ian Delaney2016-01-213-0/+944
| | | | | | | | | wrt gentoo security bug. patches added; xsa 167-4.6, xsa168 Purging of led version to await stabilsation of revbumped vns. Gentoo bug: #571556, #571552 Package-Manager: portage-2.2.26
* app-emulation/xen:-tools revbump to 4.6.0-r6 from addition of 1 upstream patchIan Delaney2016-01-122-0/+470
| | | | Package-Manager: portage-2.2.26
* app-emulation/xen-tools: remove unsupported 4.2.x seriesDoug Goldstein2016-01-063-789/+0
| | | | | Package-Manager: portage-2.2.24 Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
* app-emulation/xen-tools: re-add deps to support x86 reported in #570974Ian Delaney2016-01-062-2/+6
| | | | | | Gentoo bug: #570974 Package-Manager: portage-2.2.26
* app-emulation/xen-tools: x86 stable wrt bug #570932Agostino Sarubbo2016-01-052-2/+2
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-emulation/xen-tools: amd64 stable wrt bug #570932Agostino Sarubbo2016-01-052-2/+2
| | | | | | Package-Manager: portage-2.2.26 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-emulation/xen-tools: re-add keyword x86 to latest of vns. 4.2.5, 4.2.6Ian Delaney2016-01-052-2/+2
| | | | | | | These should never have been set to -x86 in xen-tools because they support xen guests of x86 Package-Manager: portage-2.2.26
* app-emulation/xen-tools: Make use of new python_gen_impl_dep functionMichał Górny2015-12-316-8/+8
|
* app-emulation/xen-tools: clean vn. 4.5.2-r1 re sec bug #566842Ian Delaney2015-12-232-467/+0
| | | | Package-Manager: portage-2.2.24
* app-emulation/xen-tools: amd64 stable wrt bug #566842Agostino Sarubbo2015-12-221-1/+1
| | | | | | Package-Manager: portage-2.2.24 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* app-emulation/xen-tools: revbumps to vns. 4.5.2-r3, 4.6.0-r5Ian Delaney2015-12-173-0/+937
| | | | | | | | | security patches added of xsa 164,165,166, and those effecting qemu (4) from xsa-155 re security Bug 567962 Gentoo bug: #567962 Package-Manager: portage-2.2.24
* app-emulation/xen-tools: re-add xen-tools-4.5.2-r1.ebuildIan Delaney2015-12-092-0/+467
| | | | | Package-Manager: portage-2.2.24 RepoMan-Options: --force
* clean vulnerable vns. wrt #566842 #566844Ian Delaney2015-12-093-924/+0
| | | | Package-Manager: portage-2.2.24
* app-emulation/xen-tools: revbumps -> vns. 4.5.2-r2, 4.6.0-r3 wrt sec. bugsIan Delaney2015-12-093-0/+936
| | | | | | | | | | | | Addition of patches XSA-158 (#566844), XSA-{159,160} (#566842), fixing all corresponding security issues, patches made avaialable for public release as of yesterday (08/12). Patches compressed into my devspace then combined with those of dlan insource. This format will do for now. Not to be adjusted without prior discussion. All patches pass runtests Gentoo bugs: #566842 #566844 Package-Manager: portage-2.2.24
* app-emulation/xen-tools: multiple clean upsDoug Goldstein2015-12-061-34/+19
| | | | | | | | | | | | - switch to git from mercurial for live ebuild - improve description - add sub-slot to avoid ABI breaks when upgrading/downgrading - update inherit line - fix dependency on iproute2 - fix USE=-custom-cflags to not override some FLAGS - fix up Python dependencies Signed-off-by: Doug Goldstein <cardoe@gentoo.org>
* app-emulation/xen-tools: drop udev usageDoug Goldstein2015-12-041-8/+2
| | | | | | Xen 4.6.0 and newer no longer use or ship udev rules. The functionality is implemented by running 'xl devd', which I'll add a script for on the next bump.
* app-emulation/xen-tools: fix up bad dependencyDoug Goldstein2015-12-042-2/+2
| | | | | markdown is only used when building the docs. I've confirmed this by checking the makefiles.
* app-emulation/xen-tools: clean vulnerable versions wrt security bug #566838Ian Delaney2015-12-032-928/+0
| | | | | | Gentoo bug : #566838 Package-Manager: portage-2.2.24
* app-emulation/xen-tools: add missed sec patches to vn. 4.6.0-r3Ian Delaney2015-12-031-5/+7
| | | | | | | | | Already added to xen-4.5.2-r1, fixes gentoo bug. Fix apparent typo re sec. patches in ebuild of 4.6.0-r3 only Gentoo bug: #567190 Package-Manager: portage-2.2.24
* app-emulation/xen-tools: amd64 stable wrt bug #566838Agostino Sarubbo2015-12-011-1/+1
| | | | | Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="amd64"
* app-emulation/xen-tools: revbumps vns. 4.5.2-r1, 4.6.0-r3Ian Delaney2015-12-013-0/+943
| | | | | | | | | security patches (2) added from XSA-162, initally set as embargoed security patches, publicly released today wrt the gentoo bug Gentoo bug: #566838 Package-Manager: portage-2.2.24
* app-emulation/xen-tools: clean old vns.: 4.5.1-r3, 4.6.0-r1Ian Delaney2015-11-293-918/+0
| | | | Package-Manager: portage-2.2.24
* app-emulation/xen-tools: bump seabios, fix sdl bugYixun Lan2015-11-252-0/+471
| | | | | | | | 0) bump seabios to 1.8.2, to keep sync with upstream 1) introduce USE=sdl to fix automagic dependency bug Gentoo-Bug: 565750 Package-Manager: portage-2.2.24
* app-emulation/xen-tools: x86 stable wrt bug #564472Agostino Sarubbo2015-11-101-1/+1
| | | | | Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="x86"
* app-emulation/xen-tools: amd64 stable wrt bug #564472Agostino Sarubbo2015-11-102-2/+2
| | | | | Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="amd64"
* app-emulation/xen-tools: security bump, fix XSA-153Yixun Lan2015-11-055-2/+869
| | | | | | Gentoo bug: #564472 Package-Manager: portage-2.2.23
* app-emulation/xen-tools: version bump to 4.6.0Yixun Lan2015-10-093-37/+465
| | | | Package-Manager: portage-2.2.22
* Revert DOCTYPE SYSTEM https changes in metadata.xmlMike Gilbert2015-08-241-1/+1
| | | | | | | repoman does not yet accept the https version. This partially reverts eaaface92ee81f30a6ac66fe7acbcc42c00dc450. Bug: https://bugs.gentoo.org/552720
* Use https by defaultJustin Lecher2015-08-243-12/+12
| | | | | | Convert all URLs for sites supporting encrypted connections from http to https Signed-off-by: Justin Lecher <jlec@gentoo.org>