summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-java/stax-ex: Clean up old.Patrice Clement2015-09-293-130/+0
| | | | | Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/stax-ex: Stable for amd64. Stable for ppc+x86 using the ALLARCHES ↵Patrice Clement2015-09-291-1/+1
| | | | | | | policy. Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/stax-ex: Removes java-virtual/stax-api dependency and fixes bug 561504.Patrice Clement2015-09-291-0/+33
| | | | | Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-python/sjsxp: EAPI 5 bump. Removes java-virtual/stax-api dependency and ↵Patrice Clement2015-09-281-0/+36
| | | | | | | fixes bug 561504. Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-python/jibx-tools: Removes java-virtual/stax-api dependency and fixes ↵Patrice Clement2015-09-281-0/+52
| | | | | | | bug 561504. Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-python/jibx: EAPI 5 bump. Removes java-virtual/stax-api dependency and ↵Patrice Clement2015-09-281-0/+57
| | | | | | | fixes bug 561504. Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/fastinfoset: Clean up old.Patrice Clement2015-09-283-74/+0
| | | | | Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/istack-commons-runtime: Clean up old.Patrice Clement2015-09-283-104/+0
| | | | | Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/istack-commons-runtime: Stable for amd64. Stable for ppc+ppc64+x86 ↵Patrice Clement2015-09-281-1/+1
| | | | | | | using the ALLARCHES policy. Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/dom4j: Removes java-virtual/stax-api and fixes bug 561504.Patrice Clement2015-09-281-0/+73
| | | | | Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/annogen: Removes java-virtual/stax-api and fixes bug 561504.Patrice Clement2015-09-281-0/+72
| | | | | Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/jss: Remove oldJames Le Cuirot2015-09-272-69/+0
| | | | Package-Manager: portage-2.2.20.1
* dev-java/resin-servlet-api: Remove oldJames Le Cuirot2015-09-268-355/+0
| | | | Package-Manager: portage-2.2.20.1
* dev-java/jettison: Rewrite for version bump to 1.3.7James Le Cuirot2015-09-262-0/+40
| | | | | | | Update HOMEPAGE and SRC_URI as Codehaus has gone. Java version bump to 6 removes dependency on jaxp-virtual. Package-Manager: portage-2.2.20.1
* dev-java/resin-servlet-api: Bumped to latest version, just a copy of 4.0.27 ↵William L. Thomson Jr2015-09-252-0/+49
| | | | with slot change to 3.1, tested compile and installs
* dev-java/xstream: Remove the tests so we can last-rite dev-java/staxJames Le Cuirot2015-09-261-0/+59
| | | | | | | The tests were completely broken anyway. Also update the HOMEPAGE and SRC_URI as Codehaus is dead. Package-Manager: portage-2.2.20.1
* dev-java/wstx: Bump Java version to 6 and remove tons of unneeded depsJames Le Cuirot2015-09-261-0/+58
| | | | | | | | | | | emma and xsdlib just plain aren't needed. stax and jaxp-virtual are included in Java 6. ant-nodeps and ant-trax are dummy packages. We should depend on ant-junit, not junit. Also update the homepage as Codehaus is dead. This old version is practically nowhere to be found except our mirrors. Package-Manager: portage-2.2.20.1
* dev-java/dict4j: Initial commit. Fixes bug 503758.Patrice Clement2015-09-243-0/+39
| | | | Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/jnr-unixsocket: Bump Java version to 7 as jnr-enxio also hasJames Le Cuirot2015-09-241-4/+4
| | | | | | | | | | | | | | | This relates to bug #561352. jnr-unixsocket builds with Java 6 but it should have a Java version at least as high as its dependencies. I have also changed the jnr-ffi SLOT to match the one used by jnr-enxio, otherwise you end up with two conflicting versions on the classpath. jruby (a revdep) also uses the older version but it is masked and totally broken anyway. This demands a revbump but should still be safe enough to commit straight to stable. Package-Manager: portage-2.2.20.1
* dev-java/jnr-enxio: Bump Java version to 7, fixes bug #561352James Le Cuirot2015-09-241-2/+2
| | | | | | | Bumping the Java version demands a revbump but it should still be safe enough to commit straight to stable. Package-Manager: portage-2.2.20.1
* dev-java/ibm-*-bin: Update ManifestsJonathan Callen2015-09-242-18/+18
| | | | Package-Manager: portage-2.2.20.1
* dev-java/hp-jdk-bin: Update ManifestJonathan Callen2015-09-241-2/+2
| | | | Package-Manager: portage-2.2.20.1
* Update hashes in ManifestJustin Lecher2015-09-231-1/+1
| | | | | | Add missing SHA512 and WHIRLPOOL hashes Signed-off-by: Justin Lecher <jlec@gentoo.org>
* Add missing remote idsJustin Lecher2015-09-221-0/+3
| | | | Signed-off-by: Justin Lecher <jlec@gentoo.org>
* dev-java/treelayout: New package, needed by latest antlr 4James Le Cuirot2015-09-203-0/+49
| | | | Package-Manager: portage-2.2.20.1
* dev-java/log4j: Remove oldJames Le Cuirot2015-09-172-164/+0
| | | | Package-Manager: portage-2.2.20.1
* dev-java/log4j: Dropped jmx use flag as it is in the jdk/jre since 1.5William L. Thomson Jr2015-09-171-0/+71
|
* dev-java/{mockobjects,xdoclet}: Packages removal. Fixes bug 190307.Patrice Clement2015-09-1314-967/+0
| | | | Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/{base64,java-xmlbuilder}: Packages removal. Fixes bug 557866.Patrice Clement2015-09-136-104/+0
| | | | Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/httpunit: Package removal. Fixes bug 557920.Patrice Clement2015-09-134-97/+0
| | | | Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/tclib: Package removal. Fixes bug 232666.Patrice Clement2015-09-133-45/+0
| | | | Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/istack-commons-buildtools: Stable for amd64+x86.Patrice Clement2015-09-131-1/+1
| | | | | Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/istack-commons-buildtools: Remove broken and old ebuild. Fixes bug ↵Patrice Clement2015-09-134-113/+0
| | | | | | | 276171. Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/istack-commons-buildtools: Add doc+source flags to ↵Patrice Clement2015-09-131-0/+30
| | | | | | | {JAVA_PKG_USE,IUSE}. Sort dependencies in DEPEND. Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/oracle-jdk-bin: Fix hardened + JAVA_PKG_STRICT breakageJames Le Cuirot2015-09-121-0/+3
| | | | | | We need to PaX mark javap before we run it on hardened systems. Package-Manager: portage-2.2.20.1
* dev-java/guava: Revert all changes made so far and set up a hard dependency ↵Patrice Clement2015-09-122-33/+5
| | | | | | | on Java 7. Fixes bug 560042. Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/java-sdk-docs: Remove oldJames Le Cuirot2015-09-112-50/+0
| | | | Package-Manager: portage-2.2.20.1
* dev-java/java-sdk-docs: Mark 1.8.0.60 stable as old version has goneJames Le Cuirot2015-09-111-1/+1
| | | | | | Fixes bug #560176. Package-Manager: portage-2.2.20.1
* dev-java/typesafe-config: Raise {jdk,jre} requirements to 1.8. Drop ↵Patrice Clement2015-09-111-0/+26
| | | | | | | ppc+ppc64. Fixes bug 560052. Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/java-config: Drop unnecessary dieJustin Lecher2015-09-111-1/+1
| | | | | Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
* dev-java/guava: Raise {jre,jdk} reqs to 1.7. Drop ppc64. Fixes bug 560042.Patrice Clement2015-09-101-0/+27
| | | | | Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/jfreesvg: Drop old.Patrice Clement2015-09-101-40/+0
| | | | | Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/jfreesvg: Raise {jdk,jre} reqs to 1.7. Fixes bug 559962.Patrice Clement2015-09-101-0/+40
| | | | | Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
* dev-java/oracle-jre-bin: Remove PostVMInitHook to stop usage trackerJames Le Cuirot2015-09-091-4/+5
| | | | | | | | | | | | | | | Deleting the usage tracker resulted in exceptions being silently raised in a thread and this caused havoc with debuggers. Deleting the hook that calls it instead is a smaller change and avoids both problems. It is possible that Oracle may use this hook for something else later. I have therefore added a JAVA_PKG_STRICT check to display its contents on each merge so that we can keep an eye on it. See bug #559936 for more details. Package-Manager: portage-2.2.20.1
* dev-java/oracle-jdk-bin: Remove PostVMInitHook to stop usage trackerJames Le Cuirot2015-09-091-4/+11
| | | | | | | | | | | | | | | Deleting the usage tracker resulted in exceptions being silently raised in a thread and this caused havoc with debuggers. Deleting the hook that calls it instead is a smaller change and avoids both problems. It is possible that Oracle may use this hook for something else later. I have therefore added a JAVA_PKG_STRICT check to display its contents on each merge so that we can keep an eye on it. See bug #559936 for more details. Package-Manager: portage-2.2.20.1
* dev-java/icedtea-bin: Remove vulnerable versions wrt bug #559532James Le Cuirot2015-09-083-337/+0
| | | | Package-Manager: portage-2.2.20.1
* dev-java/icedtea-bin: ppc stable wrt bug #559532Agostino Sarubbo2015-09-082-2/+2
| | | | | Package-Manager: portage-2.2.20.1 RepoMan-Options: --include-arches="ppc"
* dev-java/icedtea: Patch CACAO for a dynamic maximum heapJames Le Cuirot2015-09-076-0/+112
| | | | | | | | | It has been discovered that CACAO has been giving us memory problems because it had a fixed default heap size of only 128MB, whereas HotSpot uses a quarter of the physical RAM. I have patched CACAO to do the same. See IcedTea bugs #2611 and #2612. Package-Manager: portage-2.2.20.1
* dev-java/icedtea-bin: 6 and 7 rebuilt for ppc with dynamic heap fixJames Le Cuirot2015-09-073-4/+4
| | | | | | | | | | | | It has been discovered that CACAO has been giving us memory problems because it had a fixed default heap size of only 128MB, whereas HotSpot uses a quarter of the physical RAM. I have patched CACAO to do the same. See IcedTea bugs #2611 and #2612. 6.1.13.8-r1 goes straight to stable for amd64 and x86 because only the core ppc tarball has changed. Package-Manager: portage-2.2.20.1
* ADd missing remote-id entriesJustin Lecher2015-09-0716-5/+35
| | | | Signed-off-by: Justin Lecher <jlec@gentoo.org>