summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* dev-lang/spidermonkey: add 91.9.0Joonas Niilola19 hours3-0/+456
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: Stabilize 91.8.0 arm64, #841623Sam James13 days1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: Stabilize 91.8.0 arm, #841623Sam James13 days1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: Stabilize 91.8.0 x86, #841623Sam James13 days1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: Stabilize 91.8.0 amd64, #841623Sam James13 days1-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: Stabilize 91.8.0 ppc64, #841623Arthur Zamarin14 days1-1/+1
| | | | Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
* dev-lang/spidermonkey: drop ~s390Sam James2022-04-265-7/+7
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: enable llvm:14 on 91.8.0Joonas Niilola2022-04-101-1/+8
| | | | | Closes: https://bugs.gentoo.org/836587 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: drop 91.7.1Joonas Niilola2022-04-082-412/+0
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: add 91.8.0Joonas Niilola2022-04-082-0/+452
| | | | | | | - exclude some failing tests on ppc. Bug: https://bugs.gentoo.org/827960 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: 91.7.1 requires python[xml]Joonas Niilola2022-03-271-1/+1
| | | | | Closes: https://bugs.gentoo.org/836170 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: drop 91.7.0Joonas Niilola2022-03-222-411/+0
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: add 91.7.1Joonas Niilola2022-03-222-0/+411
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: keyword 91.7.0 for ~ppcJoonas Niilola2022-03-212-3/+3
| | | | | | | - include a new patch, details in #835575. Closes: https://bugs.gentoo.org/835575 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: Drop :52Matt Turner2022-03-125-231/+0
| | | | | | | The last reverse dependency was gnome-extra/cjs-4.6.0, dropped in 308478c39b1 ("gnome-extra/cjs: drop old") in June 2021. Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-lang/spidermonkey: drop 91.6.0Joonas Niilola2022-03-092-411/+0
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: add 91.7.0Joonas Niilola2022-03-092-0/+411
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: require newer rust for 91.6.0Joonas Niilola2022-03-011-14/+4
| | | | | Closes: https://bugs.gentoo.org/834395 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: drop 91.5.1Joonas Niilola2022-02-102-429/+0
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: add 91.6.0Joonas Niilola2022-02-092-0/+422
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: add subslot binder to icu on 68Joonas Niilola2022-02-071-1/+1
| | | | | Bug: https://bugs.gentoo.org/832775 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: unrestict icu in 68, add missing BDEPENDJoonas Niilola2022-02-071-1/+2
| | | | | Closes: https://bugs.gentoo.org/832775 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: py3.10 on 68, limit icu version, "fix" testsJoonas Niilola2022-01-291-3/+7
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: drop 91.5.0Joonas Niilola2022-01-282-425/+0
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: add 91.5.1Joonas Niilola2022-01-282-0/+428
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: update patch set for 91.5.0Joonas Niilola2022-01-222-5/+2
| | | | | | | | | | - disable some gcc-specific sanity checks (since they're not ran for clang either), - disable -Werror=format. Closes: https://bugs.gentoo.org/792246 Closes: https://bugs.gentoo.org/831501 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: enable tests for 91.5.0Joonas Niilola2022-01-182-44/+136
| | | | Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: add 91.5.0Joonas Niilola2022-01-172-0/+459
| | | | | | | - lto seems to only work with lld, and removed the MAKEOPTS hack since it broke it for me. SM takes a minute to build anyway. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
* dev-lang/spidermonkey: remove freebsd-libcDavid Seifert2022-01-022-12/+2
| | | | Signed-off-by: David Seifert <soap@gentoo.org>
* dev-lang/spidermonkey: Drop old versionsMatt Turner2021-12-296-2280/+0
| | | | Signed-off-by: Matt Turner <mattst88@gentoo.org>
* dev-lang/spidermonkey: Stabilize 78.15.0 ppc64, #822954Georgy Yakovlev2021-12-171-1/+1
| | | | Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
* dev-lang/spidermonkey: Stabilize 78.15.0 arm, #822954Sam James2021-11-141-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: Stabilize 78.15.0 arm64, #822954Sam James2021-11-131-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: Stabilize 78.15.0 x86, #822954Jakov Smolić2021-11-121-1/+1
| | | | Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* dev-lang/spidermonkey: Stabilize 78.15.0 amd64, #822954Jakov Smolić2021-11-121-1/+1
| | | | Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
* dev-lang/spidermonkey: require python[ssl]Thomas Deutschmann2021-10-232-0/+2
| | | | | | Closes: https://bugs.gentoo.org/818835 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-lang/spidermonkey: update patch setThomas Deutschmann2021-10-232-4/+11
| | | | | | | | | | | - Unbreak rust-1.56 - Allow building with LLVM 13 - Add Python 3.10 support Bug: https://bugs.gentoo.org/818016 Bug: https://bugs.gentoo.org/819486 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-lang/spidermonkey: bump to v78.15.0Thomas Deutschmann2021-10-062-0/+456
| | | | | Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-lang/spidermonkey: Stabilize 78.14.0 arm64, #814794Sam James2021-10-031-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: Stabilize 78.14.0 arm, #814794Sam James2021-10-021-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: Stabilize 78.14.0 x86, #814794Sam James2021-09-261-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: Stabilize 78.14.0 amd64, #814794Sam James2021-09-251-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>
* **/metadata.xml: Replace http by https in DOCTYPE elementUlrich Müller2021-09-111-1/+1
| | | | | Bug: https://bugs.gentoo.org/552720 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
* dev-lang/spidermonkey: bump to v78.14.0Thomas Deutschmann2021-09-062-0/+456
| | | | | Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-lang/spidermonkey: add patch to build on Linux/RISC-VThomas Deutschmann2021-09-062-0/+108
| | | | | Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-lang/spidermonkey: revbump consumers of mozcoreconf-v5.eclassSam James2021-09-042-0/+0
| | | | | | | | | | | Needed to propagate PYTHON_REQ_USE change (there's no reason the package manager must "let go" and realise it's fine to allow a Python 2 without USE=threads otherwise). See: 4bdf38313a5f6f30b916a96e1a57baf34d3b39bc See: 5e9af19749cbb9fe8702e08643522986db103b1c See: 742eeca02a0d06a56f6a69af55bcbcdf42f18ba1 Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: fix Python use dep (threads)Sam James2021-09-041-1/+1
| | | | | | | They're now always on. See: 742eeca02a0d06a56f6a69af55bcbcdf42f18ba1 Signed-off-by: Sam James <sam@gentoo.org>
* dev-lang/spidermonkey: keyword 68.12.0 for -riscvMarek Szuba2021-08-111-3/+4
| | | | | | | | | | | | | src_configure dies due to riscv being an unsupported architecture. Could be made to work by backporting 0041-bmo-1318905-Make-SpiderMonkey-build-on-Linux-RISC-V.patch from firefox-68 patch sets (it applies without errors to 68.12.0 and allows it to compile) - but given there is literally ONE package in the tree (net-libs/libproxy) requiring this particular Spidermonkey slot and it seems that it will be trivial to update to slot 78, it's probably not worth the trouble. Signed-off-by: Marek Szuba <marecki@gentoo.org>
* dev-lang/spidermonkey: bump to v78.13.0Thomas Deutschmann2021-08-112-0/+456
| | | | | Package-Manager: Portage-3.0.21, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
* dev-lang/spidermonkey: Stabilize 78.12.0 arm, #806386Sam James2021-08-091-1/+1
| | | | Signed-off-by: Sam James <sam@gentoo.org>