summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
...
* games-engines/frobtads: version bump to 1.2.4.Nikos Chantziaras2018-03-202-0/+42
| | | | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://bugs.gentoo.org/650440 Closes: https://github.com/gentoo/gentoo/pull/7454
* games-engines/openmw: Drop 0.42.0, broken by OSG-3.5.1 removalAndreas Sturmlechner2018-03-182-134/+0
| | | | Package-Manager: Portage-2.3.24, Repoman-2.3.6
* games-engines/openxcom: Drop old broken 1.0.0James Le Cuirot2018-03-172-66/+0
| | | | | Closes: https://bugs.gentoo.org/620270 Package-Manager: Portage-2.3.24, Repoman-2.3.6
* games-engines/openxcom: Add 20180317 snapshot as releases are ancientJames Le Cuirot2018-03-172-0/+62
| | | | | | | This is not tested beyond building. It's this or we drop the releases altogether as 1.0.0 no longer builds. Package-Manager: Portage-2.3.24, Repoman-2.3.6
* games-engines/openxcom: Fix 9999 icons and desktop file installationJames Le Cuirot2018-03-171-20/+4
| | | | | | | | sed broke CMakeLists.txt but this is no longer necessary anyway as upstream now use GNUInstallDirs. Closes: https://bugs.gentoo.org/623058 Package-Manager: Portage-2.3.24, Repoman-2.3.6
* games-engines/odamex: Remove useless maintainer <description/>Michał Górny2018-02-111-1/+0
| | | | | | | | | Remove useless/redundant maintainer <description/>. It does not benefit bug wrangling, and only wastes developer's time on reading it. Few tips: - assignee/CC is implied by ordering, there is no reason to repeat it, - we know that maintainer is maintainer (la la la la la), - most of adjectives for maintainer are of no value and/or are obvious.
* games-engines/openmw: Ebuild compatibility w/ >=OSG-3.5.5Andreas Sturmlechner2018-02-071-2/+7
| | | | | | | Ultimately, the nature of OSG-Qt requirement needs to be checked if only RDEPEND or also DEPEND. Package-Manager: Portage-2.3.24, Repoman-2.3.6
* games-engines/love: drop maintainershipChí-Thanh Christopher Nguyễn2018-02-011-8/+1
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* games-engines/scummvm-tools: do not install into /usr/localSven Wegener2018-01-151-1/+2
| | | | Package-Manager: Portage-2.3.14, Repoman-2.3.6
* games-engines/openmw: version bump to 0.4.3Victor2018-01-122-0/+126
| | | | | | | | | Bump version Closes: https://bugs.gentoo.org/643486 Closes: https://github.com/gentoo/gentoo/pull/6824 Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6824
* games-engines/zoom: Remove oldDavid Seifert2017-12-211-29/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/xzip: Remove oldDavid Seifert2017-12-211-33/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/solarus: Remove oldDavid Seifert2017-12-211-55/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/residualvm: Remove oldDavid Seifert2017-12-211-88/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/renpy: Remove oldDavid Seifert2017-12-211-116/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/openxcom: Remove oldDavid Seifert2017-12-211-72/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/openmw: Remove oldDavid Seifert2017-12-212-135/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/nazghul: Remove oldDavid Seifert2017-12-211-47/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/gemrb: Remove oldDavid Seifert2017-12-211-79/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/frotz: Remove oldDavid Seifert2017-12-211-50/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/frobtads: Remove oldDavid Seifert2017-12-213-96/+0
| | | | Package-Manager: Portage-2.3.16, Repoman-2.3.6
* games-engines/scummvm-tools: Removed old.Lars Wendler2017-12-181-57/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* games-engines/scummvm-tools: Bump to version 2.0.0Lars Wendler2017-12-182-0/+59
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* games-engines/scummvm: Removed old.Lars Wendler2017-12-183-218/+0
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* games-engines/scummvm: Bump to version 2.0.0Lars Wendler2017-12-182-0/+104
| | | | Package-Manager: Portage-2.3.19, Repoman-2.3.6
* games-engines/exult: Switch to Github repo (maybe bug #640700).Jeroen Roovers2017-12-151-22/+16
| | | | Package-Manager: Portage-2.3.18, Repoman-2.3.6
* games-engines/*: Update Manifest hashesMichał Górny2017-12-1018-25/+25
|
* games-engines/frobtads: [QA] Fix DESCRIPTION.toolongDavid Seifert2017-12-013-3/+3
|
* Partially revert "games-*/*: Remove stable keywords"David Seifert2017-11-192-2/+2
| | | | | | Unstabled packages not maintained by Games team. This partially reverts commit c9617875332b1b9c894c850a1f8d8dcc1897f33f. Closes: https://github.com/gentoo/gentoo/pull/6228
* games-*/*: Remove stable keywordsDavid Seifert2017-11-1821-21/+21
| | | | | | Gentoo currently does not have the manpower to maintain a ton of stable games packages. Closes: https://github.com/gentoo/gentoo/pull/5404
* games-engines/openmw: version bump to 0.42coyote2017-11-012-0/+134
| | | | Closes: https://github.com/gentoo/gentoo/pull/6018
* games-engines/stratagus: [QA] Add cmake-utils_src_prepareDavid Seifert2017-10-151-1/+5
| | | | Package-Manager: Portage-2.3.11, Repoman-2.3.3
* games-engines/stratagus: version bump to 2.4.1.Marty E. Plummer2017-10-042-0/+70
| | | | | | | | Also remove deprecated games.eclass and bump EAPI 6 to version. Package-Manager: Portage-2.3.10, Repoman-2.3.3 Signed-off-by: Marty E. Plummer <hanetzer@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/5779
* games-engines/renpy: x86 stable (bug #625624)Thomas Deutschmann2017-08-301-1/+1
| | | | Package-Manager: Portage-2.3.8, Repoman-2.3.3
* games-engines/odamex: Fix building with GCC-6Peter Levine2017-07-232-2/+42
| | | | | Bug: https://bugs.gentoo.org/show_bug.cgi?id=610566 Package-Manager: Portage-2.3.6, Repoman-2.3.2
* games-engines/renpy-6.99.12.4-r3: amd64 stableTobias Klausmann2017-07-191-1/+1
| | | | Gentoo-Bug: 625624
* games-engines/renpy: remove oldAndrew Savchenko2017-07-171-107/+0
| | | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
* games-engines/renpy: increase infinite loop hardcoded valuesAndrew Savchenko2017-07-172-0/+150
| | | | | | | | | | | | | | | On many old hardware, e.g on my Atom netbook games hit this limit, but otherwise work fine. Increasing the limit helps. People are also reporting this issue in many cases (old laptops, stow tablets, etc where games fail due to this issue and work otherwise): https://translationprojectvisualnovels.blogspot.ru/2016/09/monster-girl-quest-android-15092016.html https://lemmasoft.renai.us/forums/viewtopic.php?f=8&t=30521&start=90 https://steamcommunity.com/app/356530/discussions/0/365163686036650662/ (and many more, just google) Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
* games-engines/renpy: remove excessive dep limitationAndrew Savchenko2017-07-161-1/+0
| | | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
* games-engines/renpy: fix html docs install pathAndrew Savchenko2017-07-162-4/+4
| | | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
* games-engines/renpy: remove oldAndrew Savchenko2017-07-164-561/+0
| | | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
* games-engines/renpy: migrate from the games eclassAndrew Savchenko2017-07-161-0/+108
| | | | | | | and update to EAPI 6 Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
* games-engines/renpy: fix compat support for old gamesAndrew Savchenko2017-07-163-0/+210
| | | | | | | | - Katawa Shoujo, see bug 601200: check for window to be on list before removal - Elven Relations: do not create removed style elements Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
* games-engines/renpy: version bumpAndrew Savchenko2017-07-166-4/+638
| | | | | | | Fixes bugs 587872 and 575086. Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
* games-engines/renpy: remove old maintainersAndrew Savchenko2017-07-161-13/+0
| | | | | | | | | | | Since package was last-rited it is reasonable to assume that old maintainers have no manpower or interest to maintain this package. Made as a separate commit, so removal can be easily reverted if desired. Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
* games-engines/renpy: add myself to maintainersAndrew Savchenko2017-07-161-0/+4
| | | | | Package-Manager: Portage-2.3.6, Repoman-2.3.2 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
* *games*/*: Dekeyword ppc/ia64/sparcDavid Seifert2017-07-0812-12/+12
| | | | Closes: https://github.com/gentoo/gentoo/pull/4614
* games-engines/gemrb: x86 stable wrt bug #619790Agostino Sarubbo2017-06-011-1/+1
| | | | | | Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="x86" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* games-engines/gemrb: amd64 stable wrt bug #619790Agostino Sarubbo2017-05-271-1/+1
| | | | | | Package-Manager: Portage-2.3.5, Repoman-2.3.1 RepoMan-Options: --include-arches="amd64" Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
* games-engines/gemrb: [QA] Remove WANT_CMAKEDavid Seifert2017-05-012-31/+28
| | | | | | | * Other misc python fixes Bug: https://bugs.gentoo.org/show_bug.cgi?id=616064 Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4528