summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* */*: Remove obsolete values from PYTHON_COMPATMichał Górny2021-01-311-1/+1
| | | | Signed-off-by: Michał Górny <mgorny@gentoo.org>
* games-strategy/widelands: Do not depend on dev-lang/luaMarek Szuba2020-12-031-1/+0
| | | | | | | | | | | | | | | | | | | | | Short version: this package builds, tests and installs without any errors on systems without any versions of Lua installed, and even when a copy of Lua *is* installed does not interact with it in any way (which was already reflected by the fact dev-lang/lua was not mentioned in RDEPEND, only in DEPEND). Details: Widelands source code comes bundled with Lua - or to be precise with Eris (https://github.com/fnuecke/eris), which according to its upstream should be considered "a custom 'distribution' of Lua" due to the fact it hooks heavily into Lua internals. Since src/third_party/eris/README.eris explicitly states that the bundled Eris is what brings in the Lua version used in Widelands, it is no surprise that upstream build scripts do not even attempt to look for system Lua. Bug: https://bugs.gentoo.org/752729 Signed-off-by: Marek Szuba <marecki@gentoo.org>
* games-strategy/widelands: update homepageAlexey Sokolov2020-05-171-1/+1
| | | | | | Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexey Sokolov <sokolov@google.com> Signed-off-by: Aaron Bauman <bman@gentoo.org>
* games-strategy/widelands: Added live ebuildLars Wendler2020-03-131-0/+94
Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>